If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser hangs when saving a page

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
critical
RESOLVED WORKSFORME
15 years ago
a year ago

People

(Reporter: Martin Goldhahn, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

After selecting the "Save Page As..." menu item the browser just hangs. 
I tried several pages on different sites. 

I suspect the SP1 of WindowsXP to have something to do with it. I run the beta
of Mozilla 1.1 and it din't start at all after I installed the service pack. 

Reproducible: Always

Steps to Reproduce:
1. Open any page
2. click the "Save Page As..." menu item from the File menu

Actual Results:  
the browser hangs. It doesn't redraw itself and doesn't respond to any user input

Expected Results:  
Mozilla should save the page of course
(Reporter)

Comment 1

15 years ago
It doesn't block, it just takes an incredibly long time until the "save as" 
dialogue shows up (appr. 1 minute)

Comment 2

15 years ago
Can you provide us the URL from where you saved the webpage from?  How did the
"Save As" feature do in IE as oppose to Mozilla?
QA Contact: sairuh → petersen

Comment 3

15 years ago
Confirming this for Mozilla 1.1 final release.  It worked before Windows SP1 
and started failing immediately afterwards.

It seems to happen for all sites.  I've only seen it when saving graphics files 
(i.e. "save picture..."), but haven't tried it when saving whole pages.

In the failure, CPU usage goes to ~100% and stays there at least as long as my 
limits of patience.

IE6 is working as normal on my machine.  I haven't explictly patched IE to cope 
with Windows XP SP1, but the SP itself may have fiddled.

Comment 4

15 years ago
reporter (Martin): can you reproduce this bug with a recent build of mozilla
(for example, 1.2.1)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 5

15 years ago
it works in Mozilla 1.2.1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.