Enable selection of generated-content image used for hidden elements

VERIFIED WONTFIX

Status

()

Core
Editor
P1
critical
VERIFIED WONTFIX
19 years ago
17 years ago

People

(Reporter: Charles Manske, Assigned: mjudge)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
We are using CSS generated content (an image) to display hidden elements such
as a named anchor. The user should be able to click on this image to select
the associated named anchor.
(Reporter)

Updated

19 years ago
Blocks: 9458
(Reporter)

Updated

19 years ago
Blocks: 11771
(Reporter)

Updated

19 years ago
Blocks: 14783
(Reporter)

Updated

19 years ago
No longer blocks: 11771

Updated

19 years ago
Target Milestone: M15

Comment 1

19 years ago
setting this out past dogfood push

Comment 2

19 years ago
*** Bug 12575 has been marked as a duplicate of this bug. ***

Updated

19 years ago
OS: Windows NT → All
Priority: P3 → P2
Hardware: PC → All

Comment 3

18 years ago
moving to M17
Target Milestone: M15 → M17
(Reporter)

Comment 4

18 years ago
this needs to be specifically for the named anchor (<a name="foo">) node so
user can see that a named anchor is selected.
Severity: normal → critical
Keywords: nsbeta2
Priority: P2 → P1
Target Milestone: M17 → M16

Comment 5

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 6

18 years ago
dont need this as feature anymore. cmanske and i figured out better way to do 
what we had to do.  This may be desired to stop some selection wierdness 
behavior (aka cant continue out of generated content if you start inside it) but 
thats really a bug not a feature.

The solution for that will be check for the generated bit in the framestate. if 
its on. ask parent for its content offsets and return that as your own from 
GetContentOffsetsFromPoint. but again that is another bug.

Comment 7

18 years ago
verified in 5/16 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.