Closed Bug 1651597 Opened 3 months ago Closed 2 months ago

[TSF][ChangJie] IME candidate list not showing when inputting on webpage

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P1)

79 Branch
x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox80 --- verified

People

(Reporter: alvinhochun, Assigned: masayuki)

Details

(Keywords: inputmethod)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:79.0) Gecko/20100101 Firefox/79.0

Steps to reproduce:

  1. Enable Chinese (Traditional) Cangjie IME
  2. Place focus on any text input element on webpage (e.g. the search box on bugzilla)
  3. Enable Cangjie IME
  4. Type "竹戈" ("h" + "i"), then press spacebar

Actual results:

"么" appears with a dashed underline, but the candidate list is not visible.

Expected results:

"么" should appear with a dashed underline, and a candidate list with at least "么" and "鬼" as options. (See attachment for an example.)

OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → DOM: UI Events & Focus Handling
Product: Firefox → Core

Seems to be a regression after Firefox 78 (tested with 78.0.1, build id 20200630195452).

However when I tried to use mozregression-gui to test for earlier builds (using default settings with mozilla-central), somehow the issue is reproducible with builds as early as release 65 (as specified from the "build selection" step, I didn't tried earlier builds). This might have been affected by some nightly-only config.

Bisected some Firefox 78 beta builds

  • 78.0b7 20200612172101 ok
  • 78.0b7 20200612035411 fail

Pushlog: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=5a3d4a8ed7b8ec6988da35c387e6762a5499e135&tochange=293fc8f2ed921584a6e413aca2099acfa955e75d

This confirms that unsetting EARLY_BETA_OR_EARLIER hides the bug.

Could you take a look at this?

Flags: needinfo?(masayuki)

Hmm, really important regression Investigating...

Assignee: nobody → masayuki
Severity: -- → S1
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(masayuki)
Priority: -- → P1

Don't you set intl.tsf.hack.allow_to_stop_hacking_on_build_17643_or_later to true in about:config? Or Don't you set intl.tsf.hack.ms_traditional_chinese.* to false?

Flags: needinfo?(alvinhochun)

(In reply to Masayuki Nakano [:masayuki] (he/him)(JST, +0900) from comment #7)

Don't you set intl.tsf.hack.allow_to_stop_hacking_on_build_17643_or_later to true in about:config? Or Don't you set intl.tsf.hack.ms_traditional_chinese.* to false?

As far as I am aware, I have not changed these config values from the default.

(In reply to alvinhochun from comment #8)

(In reply to Masayuki Nakano [:masayuki] (he/him)(JST, +0900) from comment #7)

Don't you set intl.tsf.hack.allow_to_stop_hacking_on_build_17643_or_later to true in about:config? Or Don't you set intl.tsf.hack.ms_traditional_chinese.* to false?

As far as I am aware, I have not changed these config values from the default.

In early beta and Nightly channel, default value of intl.tsf.hack.allow_to_stop_hacking_on_build_17643_or_later is false. I can reproduce this bug with Nightly, but changing this pref, I cannot reproduce this bug. Additionally, I cannot reproduce this bug in release channel too. Could you check them?

I did tested that it worked in Firefox 78 stable.

Flags: needinfo?(alvinhochun)

Ah, I misunderstood the bug report. Thanks!

IIRC, when I added the pref for detecting IME regressions in Nightly channel, I've tested it with ChangJie. So, I guess that it's new regression of MS ChangJie, but there is no big update at this moment... (I can reproduce it on Win10 which is not updated to 2004.)

Severity: S1 → S2
Keywords: inputmethod
Summary: IME candidate list not showing when inputting on webpage → [TSF][ChangJie] IME candidate list not showing when inputting on webpage

Thanks, I can confirm that intl.tsf.hack.allow_to_stop_hacking_on_build_17643_or_later is the flag I need. That also explains why I wasn't getting this issue before (I only recently updated to win10 1909 from 1803).

As reported, Microsoft ChangJie is not async layout handling aware. As far as
I've tested, other IMEs for both Simplified and Traditional Chinese TIPs on
Win10. So, we should take the hack back in Nightly channel for ChangJie
even when it runs on new Win10 build.

Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/898f5c9d02d9
Enable `TS_E_NOLAYOUT` hack for Microsoft ChangJie even after Win10 build 17643 r=m_kato
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

I have reproduce this bug on an older Nightly build (2020-07-09) with steps from comment 0.

The issue is verified as fixed on 80.0 RC, under Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.