Closed Bug 1651661 Opened 3 months ago Closed 2 months ago

`HttpChannelChild::Redirect3Complete` doesn't call the channel listener on failure

Categories

(Core :: Networking: HTTP, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: mayhemer, Assigned: mayhemer)

References

(Regression)

Details

(Whiteboard: [necko-triaged])

Crash Data

Attachments

(1 file)

Calling CleanupRedirectingChannel(rv) releases the listener, but doesn't make sure OnStartRequest/OnStopRequest is called on it.

This has been introduced in bug 1294719.

Severity: -- → S3
Priority: -- → P1
Whiteboard: [necko-triaged]
Duplicate of this bug: 1649560
Crash Signature: [@ mozilla::css::StreamLoader::~StreamLoader]
Assignee: nobody → honzab.moz
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
See Also: → 1294719

(In reply to Asif Youssuff from comment #3)

Seeing this crash whenever I try to load https://www.shopgoodwill.com/

Can you please check one of the build in this try run and check? Thanks.

Flags: needinfo?(yoasif)

Honza, your try build works for me.

Flags: needinfo?(yoasif)
Pushed by honzab.moz@firemni.cz:
https://hg.mozilla.org/integration/autoland/rev/5738fd341989
Make sure we fullfil the stream listnener contract when we cannot forward an otherwise successfull HTTP redirect, r=JuniorHsu,necko-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.