main-window.ico icon looks too much like a netscape icon

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: Ian, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

I think the main-window.ico for the mozilla distributions should be updated.

I find it looks too much like the netscape icon.

I find that if you blow up the icon to a big enough size it looks OK. However
when you minimize the mozilla browser window and see the icon in the task bar I
keep on thinking that I'm running netscape.

I looked at all ther other icons and they are fine, I just a problem with this one.

For now, I'm just copying the mozilla.ico on top of the main-window.ico.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

15 years ago
Probably belongs in XPApps and affect all HW/OSes.
Assignee: asa → sgehani
Component: Browser-General → XP Apps
OS: Windows 2000 → All
QA Contact: asa → paw
Hardware: PC → All

Comment 2

15 years ago
I noticed this problem on 1.2.1, the icon that shows up in the Gnome taskbar is
the old Netscape boat-wheel icon. This is very confusing if both Mozilla and
Netscape are being used at the same time. Is there some particular reason that
we can't get all the Mozilla graphics to match? The throbber show a blue 'M'
alternating with the Red lizard, the splash screen shows what appears to be the
DMOZ/ODP green dragon thing, and now the desktop icons show old Netscape logos.
How about just using the throbber graphics as the standard and making the splash
screen and desktop icons match? 
(Reporter)

Comment 3

15 years ago
Created attachment 125579 [details]
Test case to show bug.
(Reporter)

Comment 4

15 years ago
GRRRRR... I somehow placed the attachment to the wrong bug.
Sorry!!!
(Reporter)

Updated

15 years ago
Attachment #125579 - Attachment is obsolete: true

Comment 5

14 years ago
Created attachment 133556 [details]
Screen capture of several Netscape icons still found in Moz.

I took a screenshot of my shiney new Moz 1.5, and highlighted 4 immediate
locations where the old Netscape icons are still present.  I think the new dino
icons are much more appropriate, such as the Quick Launch icon on Windows.
(Reporter)

Comment 6

14 years ago
The icon in the url bar is a netscape icon because your browser is setup to use
the netscape search engine. If you switch to Google you will see the google icon.

The icon you have highlighted in the bottom left is a theme based icon. If you
switch your theme to "modern" you will see an "M" icon witch is better. So that
icon is only related to the "classic" theme (which should be changed as well).

I think the other 2 are off the same. If one of them is changed then the other
should follow.  This is the one that I want changed.
At the very least I think it should be changed to the icon MS Windows shows for
the executable.

Here is a quick hack you can do to change the icon. (Windows version only)
	Copy [Mozilla home]\mozilla.exe to [Mozilla home]\chrome\icons\default
	In [Mozilla home]\chrome\icons\default rename main-window.ico to
main-window.bak.ico and rename mozilla.exe to main-window.ico

This is just a quick hack - you would have to redo this after every installation....

Comment 7

14 years ago
*** Bug 250523 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
Related/dup: Bug 241127

Comment 9

14 years ago
Bug 250523 Mozilla Icon is not consistent with Mozilla's "trademark"

has a suggested icon as attachment, icon, and screenshot:
http://bugzilla.mozilla.org/attachment.cgi?id=152665&action=view
http://bugzilla.mozilla.org/attachment.cgi?id=152666&action=view

Comment 10

14 years ago
Created attachment 157801 [details] [diff] [review]
Patch for XPM files

This is a patch to convert the current main icons on Unix (XPM) to the default
red dinosaur

Comment 11

14 years ago
Created attachment 157803 [details]
main-window.ico

Replacing the current main-window.ico from CVS with this one removes the old
Netscape icon. See screen captures here
http://bugzilla.mozilla.org/show_bug.cgi?id=250523

Comment 12

13 years ago
(In reply to comment #11)

For those who are interested in this patch but don't want to diff and all, I put
"installable" (exe and zip) versions on my Web site.

Link here: http://marc.bugzilla/165170-DefaultIcon/
Instructions: http://marc.bugzilla/165170-DefaultIcon/readme.html

Comment 13

13 years ago
(In reply to comment #12)

Sorry, wrong URLs. Here are the right ones:

Link here: http://marc.bugzilla.free.fr/165170-DefaultIcon/
Instructions: http://marc.bugzilla.free.fr/165170-DefaultIcon//readme.html
Product: Core → Mozilla Application Suite

Comment 14

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 15

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 16

6 years ago
*** This bug has been confirmed by popular vote. ***
Ever confirmed: true

Comment 17

6 years ago
All the icons have been replaced with the introduction of the new default theme.
Closing as WORKSFORME.
Resolution: EXPIRED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.