Closed Bug 1651762 Opened 3 months ago Closed 3 months ago

Version bump and release mozprocess + mozrunner

Categories

(Testing :: Mozbase, task, P3)

task

Tracking

(firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(2 files)

There are some Python 3 compatibility issues in mozregression detected in bug 1651058. We wonder if they may have already been fixed in mozprocess / mozrunner, but just haven't been released to pypi yet.

This release mostly contains Python 3 compatibility fixes since the last one.

There have been a few backwards incompatible changes, so bumping major version.
This also updates the minimum mozprocess to 1.2.0 to pick up the latest Py3
fixes.

Depends on D82974

Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2b334412b5f
[mozprocess] Bump to version 1.2.0, r=gbrown
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c0c57ce72c86
[mozrunner] Bump to version 8.0.0, r=gbrown
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.