Closed Bug 1651954 Opened 2 years ago Closed 3 months ago

Add an API(s) to allow editing the Tags list

Categories

(Thunderbird :: Add-Ons: Extensions API, enhancement)

enhancement

Tracking

(thunderbird_esr91 wontfix)

RESOLVED FIXED
102 Branch
Tracking Status
thunderbird_esr91 --- wontfix

People

(Reporter: florian.unger, Assigned: TbSync)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.119 Safari/537.36

Steps to reproduce:

I am trying to convert an existing legacy Addon to the new Mailextension API and miss the feature to add tags.
It is possible to query existing tags with messenger.messages.listTags()
and add existing tags to a message with messenger.messages.update(...)
but it is not possible to add new tags to the list of available tags.

Actual results:

To add a new tag to the list of available tags the user has to add the tags manually in the options menu.

In the legacy API it was possible to add tags through the tagservice:
Components.classes["@mozilla.org/messenger/tagservice;1"].getService(Components.interfaces.nsIMsgTagService);

Expected results:

It should be possible to add tags with an Mailextension API call like it was possible with the legacy tagservice.

Summary: Mailextension API feature to add tags is missing → Add an API(s) to allow editing the Tags list

Will this API be implemented or not?

Some feedback would be nice.

Duplicate of this bug: 1624059

I made an simple experiment API which implements the feature to add tags.

https://github.com/int-red/experiment-api-tagservice

Flags: needinfo?(john)
Assignee: nobody → john
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(john)
Attachment #9274893 - Attachment description: WIP: Bug 1651954 - Add API to create, modify and delete tags. r=mkmelin → Bug 1651954 - Add API to create, modify and delete tags. r=mkmelin
Version: 78 → Trunk
Target Milestone: --- → 102 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/861b6a17f926
Add API to create, modify and delete tags. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.