Closed Bug 1652056 Opened 3 months ago Closed 3 months ago

Do not use the CompilationInfo::functions array until instantiation

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: tcampbell, Assigned: tcampbell)

References

Details

Attachments

(1 file)

We no longer need access to the concrete JSFunction at any point during parse/emit so we should avoid the array existing at all until instantiation happens.

We do not need to the JSFunction during parsing any more so don't set up the
array until instantiation. During delazification we fill this array from the
existing functions, noting that the order of functions matches between lazy
and full parse by design of lazy parsing.

Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/92bedbb74f82
Don't use CompilationInfo::functions until instantiation. r=arai
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.