Closed Bug 1652452 Opened 2 years ago Closed 2 years ago

Consider to disable browser.navigation.requireUserInteraction on Nightly until regressions have been fixed

Categories

(Core :: DOM: Navigation, defect)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: smaug, Assigned: smaug)

References

Details

Attachments

(1 file)

Bug 1515073 caused couple of regressions. We shouldn't have broken behavior too long even in Nightly. So probably browser.navigation.requireUserInteraction should be disabled for now.

There's one actual regression in Nightly, bug 1644914. The other two "regressions" are a very infrequent crash that also occurs with the pref turned off and an infrequent intermittent that also occurs with the pref turned off.

So the question is whether bug 1644914, which will be fixed eventually, is too bad for Nightly. In my opinion it's not and we've had way worse bugs around for longer periods, but if you feel otherwise I understand and I would be okay with a pref-flip for now.

I'd just like to avoid pretending like we're fixing a huge number of regressions here.

Bug 1644914 is pretty bad and it has been open over a month.
In general we aren't too good at backing out patches or disabling features which cause trouble to the Nightly users.

bug 1644914 has come up in other contexts too where people thought it was regression from something else.

Assignee: nobody → bugs
Status: NEW → ASSIGNED
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90a602eade79
disable browser.navigation.requireUserInteraction even on Nightly because of regressions, r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.