Closed Bug 1653467 Opened 2 years ago Closed 2 years ago

After closing TB with unified inbox folder open, it reopens on inbox folder of first account under unified inbox

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1636350

People

(Reporter: dbkfirefox, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Close the application with the unified folder view active.

Actual results:

The application starts with the top account open.

Expected results:

Should have reopened in unified folder view as in previous versions.

Component: Untriaged → Folder and Message Lists

Wfm on 79.0b1 (32-bit), Win10

Blocks: tb78found

WFM on linux/trunk too.

David, do you still see this?

Attached image reopened.jpg

Yes it still does this, I added screen clips, the second one I had the Folder Pane tool bar turned off.

But those are both the unified view. Isn't that what your report is about? Is it about that not the same folder is selected?

The 1st shot shows the state as I closed the app, the 2nd shows after restarting the app, now it is opened to the inbox of the first account instead of the unified view.
In the 2nd photo I had the Folder pane tool bar turned off.
Thanks

Duplicate bug 1657702 reports exactly the same afasics.
wfm on Win10, 78.1.0 (64-bit) with new profile.

Summary: After closing with unified view open, the app does not open in unified view → After closing TB with unified inbox folder open, it reopens on inbox folder of first account under unified inbox

This problem is not limited to Unified folders. It also fails with "View|Folders|All". Thunderbird never restores my previously selected folder when I restart it. It always selects the first child of the first folder. The "session.json" file in the profile seems to be updated with the current URI correctly when I close Thunderbird.

(Sorry, duplicate bug 1657702 is an exact duplicate. I searched before submitting it, but not very well clearly.)

Looks like this is a duplicate of bug 1636350. (See bug 1631192.)

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Keywords: regression
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.