Closed Bug 1653483 Opened 3 months ago Closed 2 months ago

Reader mode - keep Reader controls active while tab-focused/navigated if page scrolled down

Categories

(Toolkit :: Reader Mode, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- verified

People

(Reporter: cfogel, Assigned: Gijs)

Details

Attachments

(2 files)

Attached video reader.mov

Affected versions

  • 78.0.1, 79.0b9, 80.0a1 (2020-07-15)

Affected platforms

  • macOS 10.13.6, Windows 10, Ubuntu 16;

Steps to reproduce

  1. Launch Firefox, access any article - ex: link;
  2. Scroll down the page;
  3. Click to enable Reader Mode (@adrress bar);
  4. Click on the [Aa] - Type Controls option;
  5. Move the mouse away;
  6. Press the TAB key as to tab your way through the Reader control-options;

Expected result

  • while tab-selecting the reader controls, the section should remain active(as on-hover case);

Actual result

  • control section is faded;

Regression range

  • not a regression, visible on new design;

Additional notes

  • attached recording with the issue;
  • suggested severity is S3 since it is inconsistent with the other tab-select focus styling.
Has STR: --- → yes
Summary: Reader mode - Reader controls not active while tab-focused/navigated if page scrolled down → Reader mode - keep Reader controls active while tab-focused/navigated if page scrolled down
Assignee: nobody → gijskruitbosch+bugs
Severity: -- → S4
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2040724e8c68
do not dim the reader mode toolbar while focus is inside it, r=ntim
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

Verified with 80.0a1 (2020-07-26) on above mentioned platforms.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.