Closed Bug 1653521 Opened 3 years ago Closed 2 years ago

Enable some inspector tests with Fission

Categories

(DevTools :: Inspector, task, P3)

task

Tracking

(Fission Milestone:Future)

RESOLVED DUPLICATE of bug 1691608
Fission Milestone Future

People

(Reporter: jdescottes, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

After Bug 1628473 landed, I reviewed the current inspector tests disabled for Fission.
I think 3 of them can be enabled now with test-only changes:

  • browser_inspector_navigate_to_errors.js
  • browser_inspector_open_on_neterror.js
  • browser_inspector_remove-iframe-during-load.js

Those tests can now pass with target-switching enabled and by replacing testActor usage with SpecialPowers.spawn

Tracking DevTools tests for Fission Nightly milestone (M6c).

Fission Milestone: --- → M6c
Attachment #9164283 - Attachment description: Bug 1653521 - Fix 3 DevTools Inspector tests to pass with Fission → Bug 1653521 - Enable browser_inspector_navigate_to_errors.js for fission

Such work could easily be considered as MVP. At least triaging it as reserve in order to account this work in our velocity.

Whiteboard: dt-fission-m2-reserve
Whiteboard: dt-fission-m2-reserve → dt-fission-m2-mvp
Attachment #9164283 - Attachment description: Bug 1653521 - Enable browser_inspector_navigate_to_errors.js for fission → Bug 1653521 - Fix browser_inspector_navigate_to_errors.js for fission
Attachment #9166255 - Attachment description: Bug 1653521 - Fix browser_inspector_open_on_neterror.js with Fission → Bug 1653521 - Fix browser_inspector_open_on_neterror.js for Fission
Assignee: jdescottes → nobody
Status: ASSIGNED → NEW
Whiteboard: dt-fission-m2-mvp → dt-fission-m2-reserve

Bulk move of all dt-fission-m2-reserve bugs to Fission MVP milestone.

Fission Milestone: M6c → MVP

Moving old "dt-fission-m2-reserve" bugs to "dt-fission-future" because they don't block Fission MVP.

Fission Milestone: MVP → Future
Whiteboard: dt-fission-m2-reserve → dt-fission-future

Fixed via Bug 1691608 (& Bug 1691607)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: dt-fission-future
Attachment #9164283 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.