Closed Bug 1653631 Opened 1 year ago Closed 1 year ago

Enable Constructable StyleSheets Preference for all CSSOM WPTs

Categories

(Testing :: web-platform-tests, task)

80 Branch
task

Tracking

(firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: nordzilla, Assigned: nordzilla)

Details

Attachments

(1 file)

To avoid future Web Platform Tests that deal with Constructable StyleSheets needing to be manually triaged, we should enable this pref by default for all of the CSSOM WPTs.

Pushed by abutkovits@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/41892926a339
Enable Constructable StyleSheets for CSSOM WPTs r=emilio

It looks like my patch to enable Constructable StyleSheets for all of CSSOM, and the patch to update this failing test (Bug 1651990) had a race, and my patch lost.

When I ran my push to try earlier today it came up green:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a1a67e79183f8634634630acbda985f758c015b7

I just rebased, and the changes to idlharness.ini are still not present.

I think I'm going to have to wait until I can pull the file changes and then remove what the failing WPT patch added.

Flags: needinfo?(enordin)

I ran the same Windows7 Shippable tries and they seemed to come up green.

When I run css/cssom/idlharness.html locally everything comes up fine.

I'm going to try landing this again.

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec25c0d069ae
Enable Constructable StyleSheets for CSSOM WPTs r=emilio

I believe I figured out what the issue is, thanks to chatting with Emilio.

There is a test that will be expected to fail (because the constructor does not fail) until the spec for constructable stylesheets is merged into CSSOM.

I created a bug for this and linked it in the relevant ini file.

Flags: needinfo?(enordin)
Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/83971194c08f
Enable Constructable StyleSheets for CSSOM WPTs r=emilio
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.