Closed Bug 1653637 Opened 2 years ago Closed 2 years ago

Unable to turn toolbars on or off in standalong message window

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird79 wontfix, thunderbird80 fixed)

VERIFIED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird79 --- wontfix
thunderbird80 --- fixed

People

(Reporter: dbkfirefox, Assigned: mkmelin)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

Attached image toolbars.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36

Steps to reproduce:

I was playing around with the new 78.0 version and in an open email window (NOT a new message compose window) I was right clicking around trying to customize things and came up with a option window with a couple of toolbars selected, I unchecked one just to see which one turned off and I think it was called the mail toolbar, it went away. Now I cannot find that option to turn it back on. I went to another installation and could not find where I turned it off. This also took away the 3 line control button at the right, that whole line. I need my previous and next buttons and they are gone. If I right click on the tool bar area now I get a customize button that opens the options to add buttons to the toolbar, the toolbar shows up properly while this is open, upon pressing done after changing buttons the toolbar goes away again.

I am very happy with this new version otherwise.

Actual results:

The View/Toolbars menu only shows the status bar, no other toolbar options are there, in the new mail composition window the View/Toolbars menu shows all the toolbars. I was not clicking there when this happened, I seem to remember it was around the upper right area, a small box opened with the toolbars selected, cannot find this again.

Expected results:

I don't know how I turned this off, but there should be a way to toggle the toolbars on a mail window, I had to perform a safe mode start with the option to reset toolbars and menus to get this tool bar back.
Attached is a photo of the menu with no toolbar options and the missing toolbar I am talking about.

Blocks: tb78found

(In reply to David Kelly from comment #0)

Created attachment 9164403 [details]
toolbars.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36

Steps to reproduce:

I was playing around with the new 78.0 version and in an open email window (NOT a new message compose window) I was right clicking around trying to customize things and came up with a option window with a couple of toolbars selected, I unchecked one just to see which one turned off and I think it was called the mail toolbar, it went away. Now I cannot find that option to turn it back on. I went to another installation and could not find where I turned it off. This also took away the 3 line control button at the right, that whole line. I need my previous and next buttons and they are gone. If I right click on the tool bar area now I get a customize button that opens the options to add buttons to the toolbar, the toolbar shows up properly while this is open, upon pressing done after changing buttons the toolbar goes away again.

I am very happy with this new version otherwise.

Actual results:

The View/Toolbars menu only shows the status bar, no other toolbar options are there, in the new mail composition window the View/Toolbars menu shows all the toolbars. I was not clicking there when this happened, I seem to remember it was around the upper right area, a small box opened with the toolbars selected, cannot find this again.

Expected results:

I don't know how I turned this off, but there should be a way to toggle the toolbars on a mail window, I had to perform a safe mode start with the option to reset toolbars and menus to get this tool bar back.
Attached is a photo of the menu with no toolbar options and the missing toolbar I am talking about.

Update...
I discovered how I turned this off, open an existing email, click on the 3 line menu button at the right, click on customize, it will show 3 toolbars.
If you uncheck the mail toolbar, it goes away along with the 3 line menu button therefor you cannot turn this toolbar back on or get to this menu button again.

Attached image Menu button

You can hit Alt to show the traditional menu bar. You can also right click the tab bar or the traditional menu bar. From there you can add it back.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID

Thanks I appreciate your response but you are looking in the wrong place, I have been through this on the Thunderbird help forum and they agree that this is a bug. This in on a open READING email window not a tab.
You say press alt to show the regular menu bar, well in an open reading message window that is already showing by default, that mail toolbar option is not there, that tells me you are in the wrong spot.
There is no right click any where to bring the mail toolbar back once it is turned off, only a customize button when you right click and when you press that, the mail tool bar shows up and you can add buttons, but when you hit done, the mail tool bar goes away again.

Attached image view menu

I added a screen shot of the view/toolbar menu on an open read mail window, as you can see there is no option for turning on the mail toolbar.
In this example I have already fixed the issue by the safe mode toolbar and menu reset. But the ability to turn this tool bar back on is missing.

I see. As a workaround, one can customize and drag the hamburger menu to the real traditional menu bar - and then go through that to toggle it visible.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Summary: Unable to turn toolbars on or off in mail reading window → Unable to turn toolbars on or off in standalong message window

Thanks and I see that you have found it and a workaround although when you place the "hamburger" up on the menu bar it makes it very thick, I could not see anywhere else that it would drop.
Please let the developers know the hamburger should not go away when the mail tool bar is closed causing loss of access.

Assignee: nobody → mkmelin+mozilla
Keywords: regression
Regressed by: 1608610

It's quite confusing that we call calendarOnToolbarsPopupShowing for the general case...

Anyway, the problem is that the relevant js files weren't included, so calendarOnToolbarsPopupShowing was missing, causing a js error in the console instead of setting up toolbars to show

Attachment #9166082 - Flags: review?(paul)
Comment on attachment 9166082 [details] [diff] [review]
bug1653637_standalong_win_toolbars.patch

Review of attachment 9166082 [details] [diff] [review]:
-----------------------------------------------------------------

> It's quite confusing that we call calendarOnToolbarsPopupShowing for the general case...

That is odd.  The changes look good, and I checked that this does fix the problem.

::: calendar/base/content/calendar-chrome-startup.js
@@ +550,5 @@
>      toolboxes.push("navigation-toolbox");
>    }
> +  if (toolboxId) {
> +    toolboxes.push(toolboxId);
> +  }

Good to have this guard.  I see the doc string for "getToolboxIdForCurrentTabType" says:

 * @return {string}  A toolbox id or null

But it actually never returns null, so would you mind updating that while we're here?
Attachment #9166082 - Flags: review?(paul) → review+

Is looks like it doesn't return null no. I'll update that, but then the guard is not needed so I'll remove that as well.

Attachment #9166082 - Attachment is obsolete: true
Attachment #9167144 - Flags: review+
Target Milestone: --- → 81 Branch

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/4174f515110f
bring back View|Toolbars|Mail Toolbar and Menu Bar in standalone msg window. r=pmorris

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Comment on attachment 9167144 [details] [diff] [review]
bug1653637_standalong_win_toolbars.patch

[Approval Request Comment]
Regression caused by (bug #):  1608610
User impact if declined: some items to turn on/off toolbars missing in the standalone msg window
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky): Not risky
Attachment #9167144 - Flags: approval-comm-esr78?
Attachment #9167144 - Flags: approval-comm-beta?
Comment on attachment 9167144 [details] [diff] [review]
bug1653637_standalong_win_toolbars.patch

[Triage Comment]
Approved for beta
Attachment #9167144 - Flags: approval-comm-beta? → approval-comm-beta+

I was able to turn the Mail, Menu and Status toolbars off and back on in a stand-alone window in my testing of the 80.0b2 release candidate on Ubuntu 18.04.4.

Comment on attachment 9167144 [details] [diff] [review]
bug1653637_standalong_win_toolbars.patch

[Triage Comment]
Approved for esr78

Attachment #9167144 - Flags: approval-comm-esr78? → approval-comm-esr78+

Thanks for all the work on this.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.