Closed Bug 1653792 Opened 2 years ago Closed 2 years ago

Failed to install engine: File resource://search-extensions/twitter-ja/ does not contain a valid manifest loadManifest@resource://gre/modules/addons/XPIInstall.jsm:671:11 SearchService.jsm:1293 ensureBuiltinExtension resource://gre/modules/SearchServi

Categories

(Thunderbird :: Search, defect)

defect

Tracking

(thunderbird_esr78+ fixed, thunderbird79 affected)

RESOLVED FIXED
Thunderbird 80.0
Tracking Status
thunderbird_esr78 + fixed
thunderbird79 --- affected

People

(Reporter: ishikawa, Assigned: mkmelin)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

I installed TB 78 (32-bit), Japanese locale version, a few days ago under Windows 10 (64-bit)
I noticed the error reported here in error console immediately after startup of the program (no interaction after the startup).
(See Bug 1653789, TB 78.0: Errors in error console immediately after startup of TB under Windows 10.)

Failed to install engine: File resource://search-extensions/twitter-ja/ does not contain a valid manifest
loadManifest@resource://gre/modules/addons/XPIInstall.jsm:671:11
SearchService.jsm:1293
    ensureBuiltinExtension resource://gre/modules/SearchService.jsm:1293
    AsyncFunctionThrow self-hosted:697

FYI, other errors present in the error console immediately after the startup of TB 78.0 share this "self-hosted" stuff although I am not sure what that is.
(see Bug 1634341 comment 3
https://bugzilla.mozilla.org/show_bug.cgi?id=1634341#c3 )

Version: unspecified → 78

The error here is due to Firefox having removed the search engine for Twitter. In bug 1635523, we also removed some special handling for Twitter.

There's no adverse user affects here the search service copes with missing engines just fine - obviously Twitter won't be in the list for the Japanese locales.

Either Thunderbird should follow Firefox and remove Twitter or switch to the modern configuration (bug 1612380).

Another push in bug 1635523 removed twitter-ja from browser/components/search/extensions/list.json.
We may need to remove twitter from comm-central/mail/components/search/extensions/list.json too.

Blocks: tb78found
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9166086 - Flags: review?(richard.marti)
Comment on attachment 9166086 [details] [diff] [review]
bug1653792_rm_twitter_search.patch

LGTM.
Attachment #9166086 - Flags: review?(richard.marti) → review+
Target Milestone: --- → Thunderbird 80.0
OS: Windows 10 → All
Hardware: x86_64 → All

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e770e41474f9
remove Twitter search (port bug 1635523). r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 9166086 [details] [diff] [review]
bug1653792_rm_twitter_search.patch

[Approval Request Comment]
Regression caused by (bug #): m-c bug 1635523
User impact if declined: console errors, at least
Testing completed (on c-c, etc.): yes
Risk to taking this patch (and alternatives if risky): firefox 78 removed the engine so we should as well
Attachment #9166086 - Flags: approval-comm-esr78?

Comment on attachment 9166086 [details] [diff] [review]
bug1653792_rm_twitter_search.patch

[Triage Comment]
Approved for esr78

Attachment #9166086 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.