Closed Bug 1653922 Opened 1 year ago Closed 1 year ago

Crash in [@ nsFocusManager::WindowHidden]

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- fixed

People

(Reporter: gsvelto, Assigned: kmag)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-7b504477-ffd8-4348-a664-5fe780200719.

Top 10 frames of crashing thread:

0 XUL nsFocusManager::WindowHidden dom/base/nsFocusManager.cpp:1034
1 XUL <name omitted> dom/base/nsGlobalWindowInner.cpp:4193
2 XUL nsDocumentViewer::PageHide layout/base/nsDocumentViewer.cpp:1378
3 XUL nsDocShell::FirePageHideNotificationInternal docshell/base/nsDocShell.cpp:1004
4 XUL nsDocShell::CreateContentViewer docshell/base/nsDocShell.cpp:7412
5 XUL nsDSURIContentListener::DoContent docshell/base/nsDSURIContentListener.cpp:182
6 XUL nsDocumentOpenInfo::TryContentListener uriloader/base/nsURILoader.cpp:597
7 XUL nsDocumentOpenInfo::DispatchContent uriloader/base/nsURILoader.cpp:276
8 XUL nsDocumentOpenInfo::OnStartRequest uriloader/base/nsURILoader.cpp:154
9 XUL mozilla::net::HttpChannelChild::DoOnStartRequest netwerk/protocol/http/HttpChannelChild.cpp:700

This is clearly a regression, it started with buildid 20200717093907. There are older non-nightly crashes but they're unrelated.

Component: DOM: Core & HTML → DOM: UI Events & Focus Handling
Flags: needinfo?(kmaglione+bmo)

IsSameOrAncestor used to accidentally do this when it walked the parent chain
using docshells rather than BrowsingContexts.

Assignee: nobody → kmaglione+bmo
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Duplicate of this bug: 1655011
You need to log in before you can comment on or make changes to this bug.