ign.com - Form Go Button Image w/javascript action doesn't work

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Details

(Whiteboard: [PROPRIETARY-JAVASCRIPT], URL)

(Reporter)

Description

16 years ago
Note:  Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1) Gecko/20020826

Everytime I select a menu item inside the form and click the "Go" image...
nothing happens.

Here's a piece of the page code:

<!-- begin genre selection pull down -->
<div class="browse">
<form name="genre"
action="javascript:go_page(genre.url[genre.url.selectedIndex].value)">
<table cellspacing=0 cellpadding=0 border=0><tr><td colspan=2 align=center>
<b>Choose a genre keyword:</b>
</td></tr><tr><td>
<select name="url">

 <option value="genre_1.html">Action</option>&nbsp;
*** MORE OPTIONS ON ACTUAL PAGE ***
 <option value="genre_11.html">Wrestling</option>&nbsp;

</select></td><td>&nbsp;<input type="image"
src="http://cubemedia.ign.com/cube/image/go.gif" width="38" height="24">
</td></tr></table>
</form>
</div>

<!-- end genre selection pull down -->

Comment 1

16 years ago
Same bug on w2k (build 2002082604).
The page uses IE-only syntax... it should use "document.genre", not just "genre".
Assignee: alexsavulov → susiew
Status: UNCONFIRMED → NEW
Component: Form Submission → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: vladimire → zach
Version: other → unspecified

Comment 3

16 years ago
*** Bug 171985 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Sent them an email.

Updated

16 years ago
Keywords: evang500

Updated

16 years ago
Summary: Form Go Button Image w/javascript action doesn't work → ign.com - Form Go Button Image w/javascript action doesn't work

Comment 5

16 years ago
Contact address is cube_feedback@ign.com
OS: Mac System 9.x → All
Hardware: Macintosh → All
Whiteboard: [PROPRIETARY-JAVASCRIPT]

Comment 6

15 years ago
Do we absolutely want to force web designers to rewrite this sort of code?
Apple's Safari 1.0 beta2 manages to web pages on the cube.ign.com site
that only have the genre instead of document.genre which I assume implies
Konqueror does the same!

Comment 7

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Comment 8

15 years ago
*** Bug 212967 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
IGN has revamped their entire site, this problem does not exist anymore

Article here: http://ds.ign.com/articles/573/573333p1.html
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 10

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.