Closed Bug 1654266 Opened 3 years ago Closed 3 years ago

Stopping display share stops sharing all streams

Categories

(Firefox :: Site Permissions, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- verified
firefox81 --- verified
firefox82 --- verified
firefox83 --- verified
firefox84 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

We should only stop the most recent display share when the user clicks the "Stop Sharing" button.

STR:

  1. Visit https://talky.io
  2. Click on "Start a Chat"
  3. Grant access to the camera and microphone
  4. Click "Join Call"
  5. In the Talky chat room, click "Share screen"
  6. Share a screen or window (this seems to reproduce reliably if you share a whole screen)
  7. Click "Stop sharing" in the WebRTC global sharing indicator

ER:

Sharing of the screen / window should stop.

AR:

All streams, including the microphone and camera stop being shared.

This doesn't always reproduce reliably if you only share a window, which is frustrating. We should try to figure out why.

Severity: -- → S2
Attachment #9165479 - Attachment description: Bug 1654266 - Make sure the 'Stop Sharing' button in the WebRTC indicator only stops the most recent display. r?pbz! → Bug 1654266 - Make sure the 'Stop Sharing' button in the WebRTC indicator only stops displays, and not mic/camera streams. r?pbz!
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e8a09f76574
Make sure the 'Stop Sharing' button in the WebRTC indicator only stops displays, and not mic/camera streams. r=pbz
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
Flags: qe-verify+

Reproduced the issue using Firefox 80.0a1 (20200722215545) on Windows 10x64. When clicking Stop Sharing from WebRTC Indicator all streams including the microphone and camera are closed.
The issue is verified fixed with Firefox 80.0b1 (20200728204253) on Windows 10x64, macOS 10.12 and Ubuntu 18.04. After clicking Stop Sharing button from the WebRTC global sharing indicator only the shared screen/window is stopped.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

I can also confirm that the "Stop Sharing" button stops ALL SHARING STREAMS. Confirmed on Windows 10, Windows 7, Mac OS 10.15 on Nightly 84.0a1 and Beta v83.0b4.

Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.