Closed Bug 1654699 Opened 2 months ago Closed 2 months ago

Update core-graphics/core-foundation

Categories

(Core :: Graphics, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

Details

Attachments

(1 file)

No description provided.

This includes updates to authenticator, cubeb-coreaudio,
metal, gfx-backend-vulkan, gfx-backend-metal

libloading is duplicated because of ash

Assignee: nobody → jmuizelaar
Status: NEW → ASSIGNED
Blocks: 1652876
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45fc4a780b2b
Update core-foundation/core-graphics. r=kvark,keeler,chunmin

Chun-Min, given the audio failure this is probably caused by the cubeb-coreaudio change.

Flags: needinfo?(jmuizelaar) → needinfo?(cchang)

Ah, I guess it's probably caused by cubeb-coreaudio #101. It was merged before cubeb-coreaudio #104. We know the position is inaccurate and it should be fixed in cubeb-coreaudio #99. We add some code to make sure the position is increased monotonically.

Flags: needinfo?(cchang)

Chun-Min, is it possible to switch to a branch that doesn't have the those other changes, but does have the core-foundation-sys bump so that we can get this landed without having to wait for https://github.com/ChunMinChang/cubeb-coreaudio-rs/pull/99?

Flags: needinfo?(cchang)

Paul confirmed that it's ok to land with current cubeb-coreaudio with cubeb-coreaudio #99.
I have a try push with the media tests here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=65206e8bc24c467c053d57f6ee6d787d45c375a3&selectedTaskRun=Sqtu8phhRX6iOiwqGqUsuQ.0

Flags: needinfo?(cchang)
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9702b4a4f53c
Update core-foundation/core-graphics. r=kvark,keeler,jcj,chunmin

Backed out for gtest failures

backout: https://hg.mozilla.org/integration/autoland/rev/12546a93754fc73b87d6c5775af1bcfba8220a02

push: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedTaskRun=Ucv4bzlMTeS9yT-ZxqOVlQ.0&searchStr=os%2Cx%2C10.14%2Cdebug%2Ctest-macosx1014-64%2Fdebug-gtest-1proc%2Cgtest&revision=9702b4a4f53cebd57091f33837c596706e71f069

failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=310990910&repo=autoland&lineNumber=1803

[task 2020-07-24T18:08:19.669Z] 18:08:19 INFO - TEST-START | cubeb.stream_position
[task 2020-07-24T18:08:30.614Z] 18:08:30 WARNING - TEST-UNEXPECTED-FAIL | cubeb.stream_position | Expected equality of these values:
[task 2020-07-24T18:08:30.614Z] 18:08:30 INFO - position
[task 2020-07-24T18:08:30.615Z] 18:08:30 INFO - Which is: 328316
[task 2020-07-24T18:08:30.615Z] 18:08:30 INFO - last_position
[task 2020-07-24T18:08:30.615Z] 18:08:30 INFO - Which is: 305366 @ /builds/worker/checkouts/gecko/media/libcubeb/gtest/test_sanity.cpp:549
[task 2020-07-24T18:08:30.615Z] 18:08:30 WARNING - TEST-UNEXPECTED-FAIL | cubeb.stream_position | test completed (time: 10945ms)

Flags: needinfo?(jmuizelaar)

Looks like more cubeb problems.

Flags: needinfo?(padenot)
Flags: needinfo?(jmuizelaar)
Flags: needinfo?(cchang)

I created a bmo1654699 branch for you to update the core-foundation, which updates the core-foundation without changing the position-related code.

Flags: needinfo?(cchang)
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d57a18caafb
Update core-foundation/core-graphics. r=kvark,keeler,jcj,chunmin
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Flags: needinfo?(padenot)
You need to log in before you can comment on or make changes to this bug.