Closed Bug 1654980 Opened 2 years ago Closed 1 month ago

Extreme performance degradation in Firefox 78.0

Categories

(Core :: Performance, defect, P3)

78 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ctron, Unassigned, NeedInfo)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Upgrade to Firefox 78.0.2

Actual results:

I experience extreme performance degradation. Everything becomes supper laggy. Typing text, loading pages, … and this is only inside the Firefox web browser. The rest of the system is just fine.

I also don't see any spikes in CPU usages from Firefox.

I created a performance profile, but have no idea how to read it: https://share.firefox.dev/2CyOKYX

Expected results:

No performance degradation.

Summary: Extreme performance degradation in Forefox 78.0 → Extreme performance degradation in Firefox 78.0
Component: Untriaged → Performance
Product: Firefox → Core

Compositor is busy doing something but the profile is rather restricted, so it is hard to see what.

Jens, could you see if you can reproduce using Nightly (https://nightly.mozilla.org/) and share another profile?
And could you perhaps share yet another 78 profile - looking at couple different profile might reveal where the issue could be.
It would be nice to see also the urls, but I understand if you don't want to share that kind of information.

Flags: needinfo?(ctron)

(In reply to Olli Pettay [:smaug] from comment #1)

And could you perhaps share yet another 78 profile - looking at couple different profile might reveal where the issue could be.
It would be nice to see also the urls, but I understand if you don't want to share that kind of information.

Reporter, just following up -- would you mind capturing a new profile? Also, is Firefox 79 (released this week) affected?

(Still waiting for reply to the needinfo.)

Severity: -- → S3
Priority: -- → P3

With no answer from the reporter, we don’t have enough data to reproduce and/or fix this issue. Please reopen or file a new bug with more information if you see it again.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.