Closed Bug 1655130 Opened 4 months ago Closed 3 months ago

[Regression] Can't disable smooth scrolling

Categories

(Core :: Panning and Zooming, defect, P3)

80 Branch
defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- disabled
firefox81 --- disabled
firefox82 --- fixed

People

(Reporter: grayshade, Assigned: tnikkel)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached file support.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

I have smooth scrolling disabled (but still get smooth touchpad scrolling because I'm on Wayland).

After updating from the July 17th Nightly to the July 23rd, I get smooth scrolling for keyboard (space, shift-space, page up/down, arrow keys).

Also, this only seems to kick in after the browser has been running for a while. I couldn't reproduce it with mozregression.

 6:13.87 INFO: Last good revision: 76bbb83349bb0cb72b599611d5559707fd9a8d48
 6:13.87 INFO: First bad revision: 138e7b575614cbfc1e45576a15825f51cb6e6614
 6:13.87 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=76bbb83349bb0cb72b599611d5559707fd9a8d48&tochange=138e7b575614cbfc1e45576a15825f51cb6e6614
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
Regressed by: 1651332

Thanks for reporting.

(In reply to Laurențiu Nicola from comment #0)

Also, this only seems to kick in after the browser has been running for a while. I couldn't reproduce it with mozregression.

You seemed to get mozregression working in the next comment. Did you find reliable steps to reproduce?

Flags: needinfo?(grayshade)

I can reproduce it easily using my old profile, probably because I have apz.allow_zooming enabled. I must have thought it was harder to reproduce it because of bug 1653796.

Does disabling smooth scroll work for you?

Flags: needinfo?(grayshade)

And yes, toggling apz.force_disable_desktop_zooming_scrollbars fixes it.

(In reply to Laurențiu Nicola from comment #3)

Does disabling smooth scroll work for you?

I hadn't tried yet when I commented. The reason I asked is that I was investigating something else with arrow keys yesterday and arrow keys didn't seem to go through a path touched by bug 1651332, so I was wondering if maybe there was some step I needed to take to make them. I was just trying to get as much relevant information from the reporter as possible before digging in.

Disabling smooth scroll seems to work like 90% of the time for me, 10% of the time (often the first scroll of a document) it's still smooth.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Bug 1655160 flipped the behaviour back off, so marking this bug disabled as of FF80.

Severity: -- → S3
Depends on: 1655160
Priority: -- → P3

The decision between smooth and non-smooth happens in ScrollToWithOrigin, which we don't get to with the new desktop zooming scrollbars code.

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED
Depends on: 1662013

Patch here depends on the patches in bug 1658169 too now.

Depends on: 1658169
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/375219cab02b
Handle non-smooth scrolling with desktop zooming scrollbars. r=kats
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
No longer regressions: 1664638
You need to log in before you can comment on or make changes to this bug.