Closed Bug 1655221 Opened 2 years ago Closed 2 years ago

high res videos on youtube seem to stutter or the frame rate drops

Categories

(Core :: Audio/Video: Playback, defect, P3)

78 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: planetman1125, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36

Steps to reproduce:

go to https://www.youtube.com/watch?v=F2FV4NATDvE

and set the resolution for the highest you can

Actual results:

the video seems to stutter and the frame rate drops a bit

Expected results:

the video should play smoothly like chrome

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

it seems like this could be a regression as the user seems to have this problem on 78 branch but on older branch like 77 doesn't have the issue

See Also: → 1649515

Could you try this again in Firefox Nightly? We've recently landed some patches that should improve the situation and make it easier to diagnose problems.
If you're still seeing problems, please capture a profile and share it here, by following the steps on https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem . Also, please use "Custom" profiling settings and disable the capturing of screenshots, by unchecking the "Screenshots" checkbox in the profiling settings.

Flags: needinfo?(planetman1125)

its seems worse after the fix here is my firefox profile https://share.firefox.dev/39L61dv

Flags: needinfo?(planetman1125)

Thanks for the profile! Indeed, the profile shows it's worse. We are running out of buffered images in the compositor. That's likely because of bug 1653355; we're now picking a frame one frame in the future. So we need to shift the buffering window one frame into the future as well, but I didn't do that.

(In reply to Markus Stange [:mstange] from comment #4)

Also, please use "Custom" profiling settings and disable the capturing of screenshots, by unchecking the "Screenshots" checkbox in the profiling settings.

It looks like you didn't do this part, but the profile was still useful.

Markus,
Is this issue only related with frame choosing logic in the compositor? Or it involves with playback pipeline as well?
Would you do that (shift the buffering window one frame into the future) in this bug or we already have another bug to do that?
Thank you.

Severity: -- → S3
Flags: needinfo?(mstange.moz)
Priority: -- → P3

I filed bug 1657239 on this problem and requested a backout of bug 1653355 which caused it. I think shifting the buffering window into the future should be done in bug 1653355 if we make another attempt at it.

I'm going to request another profile once the backout has made it into Nightly.

Flags: needinfo?(mstange.moz)

Could you try again on the most recent Nightly, and collect another profile if you see frame drops?

Flags: needinfo?(planetman1125)

good fix it seems to work better now.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(planetman1125)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.