Closed Bug 1655235 Opened 2 years ago Closed 2 years ago

Removing a contact using drag to another addressbook or delete loses scroll position in addressbook, resets to top

Categories

(Thunderbird :: Address Book, defect)

Unspecified
All
defect

Tracking

(thunderbird_esr78+ fixed, thunderbird81 fixed)

RESOLVED FIXED
82 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird81 --- fixed

People

(Reporter: wsmwk, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Works in 68, fails in 79 beta (and I presume also in 78)

Removing a contact using drag to another addressbook or delete loses scroll position in addressbook.

Which scroll position do you mean? Of the addressbooks? That requires quite a lot of address books....
I don't see that on trunk

I should have been clear with the steps - it loses position WITHIN an addressbook.

  • have an addressbook of say 50
  • scroll to last contact so that the first contact is now out of view
  • delete a contact
Summary: Removing a contact using drag to another addressbook or delete loses scroll position in addressbook. → Removing a contact using drag to another addressbook or delete loses scroll position in addressbook, resets to top

Another manifestation of this, is when a search is performed with All Address Books selected, and you drag a contact to another address book, the list of contacts goes blank - at least on 81 beta

Flags: needinfo?(geoff)

That'll be caused by these three lines. I don't know why they exist.

Flags: needinfo?(geoff)

Comment 0 will be from these lines … I know why they exist, but I wonder if I can get rid of them now.

Assignee: nobody → geoff
Status: NEW → ASSIGNED

(In reply to Geoff Lankow (:darktrojan) from comment #5)

Comment 0 will be from these lines … I know why they exist, but I wonder if I can get rid of them now.

I decided not to, given that this patch should be uplifted I didn't want to cause a regression with it. I had to add the getFirstVisibleRow/scrollToRow bit anyway so removing those lines made no difference.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/ee88f4ff9950
Fix address book scroll and drag problems. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Attachment #9172956 - Flags: approval-comm-beta?

Comment on attachment 9172956 [details]
Bug 1655235 - Fix address book scroll and drag problems. r?mkmelin

[Triage Comment]
Approved for beta

Let's remember to test the candidate build

Flags: needinfo?(wls220spring)
Flags: needinfo?(vseerror)
Attachment #9172956 - Flags: approval-comm-beta? → approval-comm-beta+

Looks like it is working properly in my testing of 81.0b3 on Ubuntu 18.04 LTS.

Flags: needinfo?(wls220spring)

Comment on attachment 9172956 [details]
Bug 1655235 - Fix address book scroll and drag problems. r?mkmelin

[Approval Request Comment]
Regression caused by (bug #): Bug 1636019 et al.
User impact if declined: UI glitch
Testing completed (on c-c, etc.): Since 81.0b3.
Risk to taking this patch (and alternatives if risky): Small.

Attachment #9172956 - Flags: approval-comm-esr78?

Comment on attachment 9172956 [details]
Bug 1655235 - Fix address book scroll and drag problems. r?mkmelin

[Triage Comment]
Approved for esr78

Flags: needinfo?(vseerror)
Attachment #9172956 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.