Closed Bug 1655289 Opened 4 months ago Closed 4 months ago

Graphic anomalies on "Account Central"

Categories

(Thunderbird :: General, defect, P2)

Tracking

(thunderbird_esr78 fixed, thunderbird78 wontfix, thunderbird79 wontfix, thunderbird80 fixed)

VERIFIED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird78 --- wontfix
thunderbird79 --- wontfix
thunderbird80 --- fixed

People

(Reporter: jorgk-bmo, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

See attached image.

I also noticed that windows for Email, Address Book, etc. open centre screen, but Calendar doesn't.

Alex, did you implement this?

Flags: needinfo?(alessandro)

Mhhh, it seems that the email tooltip remained visible, probably a focus issue, I'll take a look.
I'll see why some dialogs open at the center of the screen and others at the center of the application.

Flags: needinfo?(alessandro)
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Keywords: regression
Priority: -- → P2
Attached patch 1655289-account-central.diff (obsolete) — Splinter Review

This removes the showing of the button description on focus, since we can't control the focus ring if a user clicks on a button and then hovers over another button, the 2 descriptions will show at the same time.
Let's remove it for safety.

I set centerscreen for the Calendar dialog, but I don't think it'll fix it since some dialogs are modals, and some aren't, so putting centerscreen will sometimes open at the center of TB, or at the center of your screen, and I don't think I can't control that.

I'm launching a 78 try-run for you to test, Jorg.

Attachment #9166427 - Flags: review?(richard.marti)

Here's a 78 Windows try-run (still building at the time of this message): https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=82c7557ee6b07ae24e883e5f28be3e2cb0cb3724

Comment on attachment 9166427 [details] [diff] [review]
1655289-account-central.diff

The tooltips don't overwrite theme any more, good. But the Calendar dialog opens still on top left.

What happens here:
- Email centre screen
- Calendar top left. But it saves the position. When moved to an other position it opens the there.
- Address Book centre TB
- Chat centre TB
- Feeds centre TB
-Newsgroups centre TB

We should look that they all open at the same position, preferably centre TB. On a big screen, I have a 3440 * 1440 screen, the centre screen and the centre TB can be on totally other positions.
Attachment #9166427 - Flags: review?(richard.marti) → review-

Now all the dialogs should open as modals at the center of TB.

A little heads up about this issue reported 5 years ago, which I can't reproduce, so I think we can assume we can drop the workaround: https://searchfox.org/comm-central/rev/306ca78c3d2d1b7a247d670c26d2dd719b8df4da/calendar/base/modules/utils/calWindowUtils.jsm#29

Attachment #9166427 - Attachment is obsolete: true
Attachment #9166649 - Flags: review?(richard.marti)

Just to leave a note somewhere, this will need a separated 78 variation as it doesn't merge normally.
I'll take care of it after it gets an r+

Comment on attachment 9166649 [details] [diff] [review]
1655289-account-central.diff

Thanks, looks good now. I don't see Bug 1151440 on my Ubuntu Linux, so removing this workaround should be okay.
Attachment #9166649 - Flags: review?(richard.marti) → review+
Target Milestone: --- → Thunderbird 80.0
Comment on attachment 9166649 [details] [diff] [review]
1655289-account-central.diff

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: Conflict between hover and focus effect on Account Hub button description, and wizard dialogs not always opening at the center of the application.
Testing completed (on c-c, etc.): soon on c-c
Risk to taking this patch (and alternatives if risky): moderate as we removed some previous workaround for old (5+ years) Linux issues. I recommend keeping this on trunk and beta to be sure nothing was affected.
Attachment #9166649 - Flags: approval-comm-esr78?

81

Target Milestone: Thunderbird 80.0 → 81 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/355771da5346
Fix UI issues with tooltips and opening dialogs in new Account Central. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Regressions: 1656360
Comment on attachment 9166649 [details] [diff] [review]
1655289-account-central.diff

With the TM change, this needs uplift to beta 80 ...

[Triage Comment]
Approved for beta
Attachment #9166649 - Flags: approval-comm-beta+

I just flagged bug 1656360 for beta and esr uplift.
That needs to land together with this patch as it fixes a pretty annoying regression.

Flags: needinfo?(vseerror)
Status: RESOLVED → VERIFIED

Forgot the comment.

Tested in 80.0b2 on Ubuntu 18.04.4.

Comment on attachment 9166649 [details] [diff] [review]
1655289-account-central.diff

[Triage Comment]
Approved for esr78

Flags: needinfo?(vseerror)
Attachment #9166649 - Flags: approval-comm-esr78? → approval-comm-esr78+
Regressions: 1659241
You need to log in before you can comment on or make changes to this bug.