Closed Bug 165534 Opened 18 years ago Closed 18 years ago

Javascript pop up windows are too small.

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 149077

People

(Reporter: john_pilbeam, Assigned: asa)

References

()

Details

Causes problems with pop up windows on my own site (password protected).

The problem seems to be that IE takes the Javascript defined window size to be
the canas area of the window, excluding the width of scroll bars. Mozilla works
on the basis that the pop up window size is the Javascript defined window size
plus the size of scroll bars. This means than Mozilla always draws pop ups that
are about 20px too short and 20px too narrow, with ugly scroll bars. 

Code:

<script language="JavaScript">
    function openNewWindow(URLtoOpen, windowName, windowFeatures) {
        newWindow=window.open(URLtoOpen, windowName, windowFeatures);
    }
</script>
reporter, please note that ~35% of new bugs are duplicates, to ensure
that we respond to user queries efficiently, please search for
duplicates before filing a bug report.

see http://www.mozilla.org/quality/bug-writing-guidelines.html

*** This bug has been marked as a duplicate of 149077 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.