Closed Bug 1655374 Opened 3 months ago Closed 3 months ago

Intermittent comm/mail/components/addrbook/test/browser/browser_mailing_lists.js | mailing list ("Mochitest Mailing List (modified)") is displayed in the address book list

Categories

(Thunderbird :: Address Book, defect, P5)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird80 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird80 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: aleca)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Assignee: nobody → alessandro
Status: NEW → ASSIGNED

Not sure why, but for some reason using the synthesizeMouseAtCenter and the sendKey("END") one after another was causing the cursor to stop in the middle of the input field.
Simply focusing the field before using the END key stroke seems to have fixed it.

Locally the tests pass.
Here's a try-run to be sure I didn't break anything else: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=4c074a6abd2f020677a9a1cc86b2c1cb9f6a972c

Attachment #9167107 - Flags: review?(geoff)

So, the good news is that the mailing list test have been fixed.
Bad news is that with my recent push to C-C, new test popped out due to a regression I introduced, yay.
I already filed bug 1656360 for those new failures.

Comment on attachment 9167107 [details] [diff] [review]
1655374-test.diff

Weird. I wonder why this only happens on Mac (or why it happens at all, more to the point). Thanks for looking into this.
Attachment #9167107 - Flags: review?(geoff) → review+
Target Milestone: --- → 81 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/48f55b31962b
Fix intermittent browser_mailing_lists.js test failure. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Comment on attachment 9167107 [details] [diff] [review]
1655374-test.diff

This has appeared on beta and ESR. Looking at what landed there, I still don't know why.
Attachment #9167107 - Flags: approval-comm-esr78?
Attachment #9167107 - Flags: approval-comm-beta?

Comment on attachment 9167107 [details] [diff] [review]
1655374-test.diff

[Triage Comment]
Approved for beta

Attachment #9167107 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9167107 [details] [diff] [review]
1655374-test.diff

[Triage Comment]
Approved for esr78

Attachment #9167107 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.