Mail should send email in background

RESOLVED DUPLICATE of bug 126140

Status

--
enhancement
RESOLVED DUPLICATE of bug 126140
17 years ago
10 years ago

People

(Reporter: tack-bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Even with bug 129495 out of the way, sending mail is still awkwardly slow.  I've
not spent any time profiling it because I realized the speed issue is moot if
the sending process takes place in the background, like for example the way
Evolution does it.  (When you click send, the compose window goes away
immediately, and the status bar reflects the send message progress.)

This is really the way Mozilla mail should do it.  Even if the message takes 10
seconds to send and copy to sent folder (which it sometimes does, even with
recent builds with the fix for bug 129495 included, over a local network), the
user will not notice or care if this operation is backgrounded.

Updated

17 years ago
Component: Networking: MailNews General → Networking: SMTP
QA Contact: huang → meehansqa
(Reporter)

Comment 1

17 years ago
The reason I chose Networking: MailNews General, as opposed to Networking: SMTP
for the component was that I think copying the message to an IMAP sent folder,
which is often part of the "sending an email" operation, should also be
backgrounded.  And copying to an IMAP folder is obviously not an SMTP function.

Comment 2

17 years ago
please read bug 126140 comment 2

*** This bug has been marked as a duplicate of 126140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.