Closed Bug 1655443 Opened 3 months ago Closed 3 months ago

Improve design for private field Proxy support

Categories

(Core :: JavaScript Engine, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: mgaudet, Assigned: mgaudet)

References

Details

Attachments

(1 file)

During a conversation Jason proposed a simpler design for our Proxy support for private fields.

It's clearly better, so we should do it.

Pushed by mgaudet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eea58922fd27
Redesign private name proxy support to be more clear and simpler r=jorendorff
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Duplicate of this bug: 1654278
You need to log in before you can comment on or make changes to this bug.