Modal dialog does no longer react and makes browser unusable

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: kaie, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I can not reproduce this.
I was using the official ns7 build.

I opened the mail preferences dialog.
Once it was open, I was unable to click anywhere in the browser.
Pressing the window manager UI close control didn't work.
Pressing the Escape keyboard key didn't work.

However, the application was not hung.
I was still able to switch between open browser windows, and redraw worked
everywhere. But nothing reacted, probably because that pref dialog is modal.

I think the following message on my console might have come from Mozilla:
Gtk-CRITICAL **: file gtkdnd.c: line 623 (gtk_drag_get_data): assertion `widget
!= NULL' failed.
(Reporter)

Comment 1

16 years ago
You probably already assumed, but to clarify: I had to kill the process the hard
way.
Summary: Modal dialog does no longer react → Modal dialog does no longer react and makes browser unusable
(Reporter)

Comment 2

15 years ago
I never saw this again, and apparently, nobody else did.
Marking worsforme.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 3

15 years ago
> I never saw this again, and apparently, nobody else did.

Don't be so sure. Bug 200041 sounds mighty similar....
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.