Closed Bug 1655999 Opened 2 months ago Closed 2 months ago

The devtools.performance.recording.ui-base-url pref rejects "netlify.app" deploy preview URLs

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect

Tracking

(firefox80 fixed, firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox80 --- fixed
firefox81 --- fixed

People

(Reporter: mstange, Assigned: julienw)

Details

Attachments

(1 file)

This regex currently only allows netlify.com:

https://searchfox.org/mozilla-central/rev/d9f92154813fbd4a528453c33886dc3a74f27abb/devtools/startup/DevToolsStartup.jsm#286

      // Allows the following:
      //   "https://deploy-preview-1234--perf-html.netlify.com"
      //   "https://deploy-preview-1234--perf-html.netlify.com/"
      //   "https://deploy-preview-1234567--perf-html.netlify.com"
      /^https:\/\/deploy-preview-\d+--perf-html\.netlify\.com\/?$/.test(
        targetUrl
      )
    ) {

But netlify encourages using netlify.app these days.

Netlify recently moved from netlify.com to netlify.app for their
deployed URLs.

Assignee: nobody → felash
Status: NEW → ASSIGNED
Attachment #9166857 - Attachment description: Bug 1655999 - Support netlify.app URLs for deploy previews r=canaltinova! → Bug 1655999 - Support netlify.app URLs for the profiler frontend code deploy previews r=canaltinova!
Pushed by jwajsberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62d7b5de50e5
Support netlify.app URLs for the profiler frontend code deploy previews r=canaltinova

Comment on attachment 9166857 [details]
Bug 1655999 - Support netlify.app URLs for the profiler frontend code deploy previews r=canaltinova!

Beta/Release Uplift Approval Request

  • User impact if declined: It's not possible to test profiler frontend's new code with the beta channel.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is not risky because this code isn't used by end-users but rather gecko developers. Moreover this is used when the user changes about:config, so this is really for advanced developers.
  • String changes made/needed:
Attachment #9166857 - Flags: approval-mozilla-beta?

Comment on attachment 9166857 [details]
Bug 1655999 - Support netlify.app URLs for the profiler frontend code deploy previews r=canaltinova!

approved for 80.0b2

Attachment #9166857 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.