"Error 126" when trying to launch mozilla as a non-root user

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
blocker
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: gthornock, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Opera/6.0 (Linux 2.4.18-4.ynefel.xfs i686; U)  [en]
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.1/Red_Hat_7x_RPMS/RPMS/i386/

I tried installing Mozilla 1.1 yesterday using the RPMs from the ftp site.  
Anytime I try to launch the program as a non-root user, I get an "error 126" 
message and the program terminates.  Everything seems to work fine when 
running as root.

Reproducible: Always

Steps to Reproduce:
1. Download the Mozilla 1.1 rpms
2. rpm -Fvh *
3. su - some-non-root-user
4. mozilla &

Actual Results:  
"error 126", and mozilla didn't start.

Expected Results:  
I would have expected the program to start :)

This may not be relevant, but I'm running Red Hat 7.3 on an Athlon with 1.25 
gig of RAM.

Comment 1

16 years ago
could you try
1. uninstall mozilla
2. nuke the mozilla directory (/usr/lib/mozilla-1.1) (save any plugins or
re-install them later)
3. re-install mozilla

you might also check to make sure the all the files have read permission and the
libs and directories have execute permission
(Reporter)

Comment 2

16 years ago
I have already tried all of those things.  None of them worked.

Comment 3

16 years ago
Is this bug a duplicate of bug 88822 = "as non-root user, mozilla segfaults upon
startup and fails to load (fine as root) ?
(Reporter)

Comment 4

16 years ago
It may be.  I'm not sure.  The behavior is certainly similar, although I didn't
see any specific error code associated with 88822.

Comment 5

16 years ago
bug 88822 won't occur with an RPM build.  it is talkback-related

Comment 6

16 years ago
Did you just "su - non-root-user" in root's xterm under X running as root? 
Might be problem with X dislay permissions - have you tried launching other
Xwindows programs this way? (log out as root and log in as that user then)
(Reporter)

Comment 7

16 years ago
No, I logged in as a non-root user first, encountered the error, and _then_
su-ed root and tried again.

Comment 8

16 years ago
I could always run the latest RPMs. Could you try a newer version (if you use
MailNews, don't try 1.2b).

pi

Comment 9

16 years ago
Using the latest rpms, or the lastes build (2002102508), with the steps outlined
in the description of this bug, I could not reproduce this bug.  Therefor, I am
marking this as WORKSFORME.  Reporter, please reopen this bug if you can provide
steps to reproduce the bug in a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.