Closed Bug 1656421 Opened 2 years ago Closed 2 years ago

Use the viewport frame size for the clip rect if there is no root scroll frame

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

Details

Attachments

(1 file)

From a review comment by Botond;

Some XUL documents in the browser chrome don't have a root scroll frame. Not sure if those can have prerendered animations.

It looks like browser/components/downloads/test/browser/browser_downloads_autohide.js is a such test cases. And interestingly the assertion doesn't happen on Linux at all, seems like it only happens on Windows.

I'd like to know the reason why there is no root scroll frame. Actually I tried to reproduce the assertion on my Windows 10 laptop (Thinkpad T460p), but can't reproduce so far.

Got a frame dump in a try run;

Viewport(-1)@1868d513020 [view=1868c533380] (0,0,76800,61860) [cs=18695f3e208:-moz-viewport] <
Canvas(html)(-1)@1868d5130c8 parent=1868d513020 (0,0,76800,61860) [content=1868a202af0] [cs=18696bc2c58:-moz-canvas] <
Block(html)(-1)@1868d5131a8 parent=1868d5130c8 next=1868d513338 (0,0,76800,61860) [content=1868a202af0] [cs=1869051c2f8] <
line@1868bccc020 count=1 state=block,clean,prevmarginclean,not-impacted,not-wrapped,before:nobr,after:nobr[0x148] (0,0,76800,61860) <
Box(body)(3)@1868d5137c8 parent=1868d5131a8 next=1868bcc0d50 (0,0,76800,61860) [content=1868a202e50] [cs=1868f0a1108] <
Box(popupset)(10)@1868d513898 parent=1868d5137c8 next=1868bca0788 (0,0,76800,0) ink-overflow=(0,0,76800,60) scr-overflow=(0,0,76800,60) [content=1868a20f160] [cs=1868d598208] <

Indeed, there is no root scroll frame. Anyways I am going to use the viewport frame size in such cases.

Assignee: nobody → hikezoe.birchill
Status: NEW → ASSIGNED
Severity: -- → S3
Priority: -- → P3
Pushed by hikezoe.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ffbb586b294
Use the viewport frame size for the clip rect if there is no root scroll frame. r=botond
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.