Closed Bug 1656680 Opened 6 months ago Closed 6 months ago

Permafailing browser/base/content/test/static/browser_all_files_referenced.js | there should be no unreferenced files - Got 1, expected +0 when Gecko 81 merges to Beta on 2020-08-24

Categories

(Toolkit :: Telemetry, defect, P1)

defect

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 + verified

People

(Reporter: nataliaCs, Assigned: chutten)

References

(Regression)

Details

Attachments

(1 file)

Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=78dd7ddb1389a42dba2ebfad33c57fbaf9213ab4&test_paths=browser%2Fbase%2Fcontent%2Ftest%2Fstatic%2Fbrowser.ini&group_state=expanded

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=311738883&repo=try&lineNumber=1403

[task 2020-08-01T12:14:36.906Z] 12:14:36 INFO - indirectly whitelisted file: resource://services-sync/doctor.js used from resource://services-sync/bookmark_repair.js,resource://services-sync/stages/enginesync.js
[task 2020-08-01T12:14:36.907Z] 12:14:36 INFO - Buffered messages finished
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | there should be no unreferenced files - Got 1, expected +0
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - Stack trace:
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - chrome://mochikit/content/browser-test.js:test_is:1327
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:checkAllTheFiles:950
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_all_files_referenced.js | unreferenced file: resource://gre/localization/en-US/toolkit/about/aboutGlean.ftl -
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - Stack trace:
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2020-08-01T12:14:36.909Z] 12:14:36 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_all_files_referenced.js:checkAllTheFiles:954
[task 2020-08-01T12:14:36.910Z] 12:14:36 INFO - ignored unused whitelist entry: resource://app/blocklist.xml
[task 2020-08-01T12:14:36.912Z] 12:14:36 INFO - ignored unused whitelist entry: resource://gre/gmp-clearkey/0.1/manifest.json
[task 2020-08-01T12:14:36.912Z] 12:14:36 INFO - ignored unused whitelist entry: resource://gre/res/test.properties
[task 2020-08-01T12:14:36.912Z] 12:14:36 INFO - missing file: chrome://global/content/aboutProcesses.html

Possibly related to Bug 1647187 ?

Flags: needinfo?(gbrown)

unreferenced file: resource://gre/localization/en-US/toolkit/about/aboutGlean.ftl points to Bug 1635253.
Chris, do you mind taking a look at this beta-sim bug? Thank you.

Flags: needinfo?(gbrown) → needinfo?(chutten)
Regressed by: 1635253
No longer regressed by: 1647187
Component: General → Telemetry
Product: Firefox → Toolkit

Hm...

about:glean is only included when MOZ_GLEAN is set. MOZ_GLEAN is, for now, only set on (non-Android) Nightly.

I'm not sure how to mark about:glean's translations are to be conditionally included... :flod, can you help me?

Flags: needinfo?(chutten) → needinfo?(francesco.lodolo)

Not really my area, but I can't help noticing several FTL files excluded in that test
https://searchfox.org/mozilla-central/source/browser/base/content/test/static/browser_all_files_referenced.js#87

Front-end folks like Gijs or Jaws might know if that's the correct approach here.

Flags: needinfo?(francesco.lodolo)

(In reply to Chris H-C :chutten from comment #3)

Hm...

about:glean is only included when MOZ_GLEAN is set. MOZ_GLEAN is, for now, only set on (non-Android) Nightly.

I'm not sure how to mark about:glean's translations are to be conditionally included... :flod, can you help me?

Flags: needinfo?(gijskruitbosch+bugs)

If the information in bug 1526672 is still valid these 2 years later, looks like that allowlist is the way to go.

(In reply to Chris H-C :chutten from comment #6)

If the information in bug 1526672 is still valid these 2 years later, looks like that allowlist is the way to go.

Yeah, add an item to the allowlist iff the conditions for it being referenced match.

Flags: needinfo?(gijskruitbosch+bugs)

Dang. The allowlist has an integrity test to ensure all items are used. Not all items are used in Nightly builds, and there's no current way to ifdef out on channel.

Lemme augment the allowlist's capabilities. Sorry I couldn't get to this today.

Assignee: nobody → chutten
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P1

(In reply to Chris H-C :chutten from comment #8)

Dang. The allowlist has an integrity test to ensure all items are used. Not all items are used in Nightly builds, and there's no current way to ifdef out on channel.

There is already such a way - see e.g. https://searchfox.org/mozilla-central/rev/a315a1a0f09550e23e4590a77e74f36543315da3/browser/base/content/test/static/browser_all_files_referenced.js#228-234 .

(In reply to :Gijs (he/him) from comment #9)

(In reply to Chris H-C :chutten from comment #8)

Dang. The allowlist has an integrity test to ensure all items are used. Not all items are used in Nightly builds, and there's no current way to ifdef out on channel.

There is already such a way - see e.g. https://searchfox.org/mozilla-central/rev/a315a1a0f09550e23e4590a77e74f36543315da3/browser/base/content/test/static/browser_all_files_referenced.js#228-234 .

Ah, thank you. Patch incoming.

But only on not-nightly or android builds.

Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1552fde523bc
Allow aboutGlean.ftl to be unreferenced r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Verified fixed with yesterday's central-as-beta simulation.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.