Closed Bug 1656693 Opened 1 year ago Closed 1 year ago

Calendar New Event window no longer starts with highlighted title.

Categories

(Calendar :: Dialogs, defect, P2)

Thunderbird 78

Tracking

(thunderbird_esr78 fixed, thunderbird78 affected, thunderbird79 affected, thunderbird80 fixed, thunderbird81 affected)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird78 --- affected
thunderbird79 --- affected
thunderbird80 --- fixed
thunderbird81 --- affected

People

(Reporter: mendopaul99, Assigned: khushil324)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.105 Safari/537.36

Steps to reproduce:

Build 78.1.0
New Event (In Calendar)

Actual results:

Dialogue Window shows "New Event" in title window but not highlighted.

Expected results:

In previous versions the title would be highlighted so that typing could begin immediately.
Now the user must do a Tab to get to the field. On a Mac this would be a violation of the UI guidelines. Don't know about PC guidelines, but it is now a pain.
Identical problem with New Task.
Moving the Calendar field above the Title field (why?) has caused this problem.

I see the same using 78.1.0 on Ubuntu 18.04.4 LTS Linux.

Status: UNCONFIRMED → NEW
Component: Untriaged → Dialogs
Ever confirmed: true
Keywords: regression
OS: Unspecified → All
Product: Thunderbird → Calendar
Hardware: Unspecified → All
Version: 78 → Thunderbird 78

Yes this is because the calendar is now first, while the title was first before. I'm not sure it's a bug or not. On one side it makes sense to let the focus go from top to bottom, but I suppose there's a case for still moving the initial focus + selection to the title.

Yes, I think we should have the initial focus and selection on the title field.
Even if the calendar menulist is above it, we assume that option is accurate based on the currently selected calendar of the user, so the most obvious first interaction with that dialog should be the event title.

Assignee: nobody → khushil324
Priority: -- → P2
Status: NEW → ASSIGNED
Comment on attachment 9169447 [details] [diff] [review]
Bug-1656693_calendar-new-event-title-focus-0.patch

Review of attachment 9169447 [details] [diff] [review]:
-----------------------------------------------------------------

Code changes look fine.  (It does seem odd and inconsistent to focus the second item and not the first, but... if calendar is going to be first then this seems like a necessary step for better UX.)
Attachment #9169447 - Flags: review?(paul) → review+
Regressed by: 1569562

Comment on attachment 9169447 [details] [diff] [review]
Bug-1656693_calendar-new-event-title-focus-0.patch

[Approval Request Comment]
Regression caused by (bug #): 1569562
User impact if declined: Event creation and handling UX will be impacted.
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky): Low.

Attachment #9169447 - Flags: approval-comm-esr78?
Attachment #9169447 - Flags: approval-comm-beta?

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/c1668ce5c81e
Fix Calendar New Event window no longer starts with highlighted title. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Comment on attachment 9169447 [details] [diff] [review]
Bug-1656693_calendar-new-event-title-focus-0.patch

[Triage Comment]
Approved for beta
Approved for esr78

Attachment #9169447 - Flags: approval-comm-esr78?
Attachment #9169447 - Flags: approval-comm-esr78+
Attachment #9169447 - Flags: approval-comm-beta?
Attachment #9169447 - Flags: approval-comm-beta+

Well, the Title field now has a blinking bar after "New Event" or "New Task", but not the highlighted color like before where the user could just start typing. I can live with having to backspace to remove "New Event", "New Task" and start typing.

Tested in TB 80.0b4 on Ubuntu 18.04.4 LTS.

Reporter, will that work for you?

Flags: needinfo?(mendopaul99)

I think putting the cursor at the end of "New Event"/"New Task" instead of making it the focus is not an improvement and is not at all intuitive. I have never seen in any UI where a cursor is left after a prompt that is meant to disappear.

At least now the single keystroke of <tab> makes it the focus. A better solution would be to put the title field back to first position, like it was before. But please don't make it worse.

Flags: needinfo?(mendopaul99)

The single keystroke of <Tab> works to focus the Title field in TB 78..1.1, which doesn't have the bug fix.

If I would have tried that and see that it highlights "New Event" which allows the user to start typing as before, I may have not confirmed the bug and considered it a support issue.

Agreed that's not very good. Filed bug 1659380.

You need to log in before you can comment on or make changes to this bug.