Closed Bug 165687 Opened 19 years ago Closed 18 years ago

crash when closing tabs with additional XUL-applications [@ GlobalWindowImpl::GetScrollInfo]

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 155681

People

(Reporter: dewildt, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

I don't know of this problem belongs only to Mozilla or to additional
(XUL-)application I have installed from the URL.
I had installed and was testing the following XUL-applications (sorry for the
overhead) :
*) ContextMenu-Extension:
http://www.cc-net.or.jp/~piro/xul/_moz-extensions.html
*) Tabbrowser-Extension:
http://www.cc-net.or.jp/~piro/xul/_tabextensions.html
*) Sidebar-Extension:
http://www.cc-net.or.jp/~piro/xul/_floatingsidebar.html
*) Policy-Manager:
http://www.cc-net.or.jp/~piro/xul/_policymanager.html

I think the problem could be the Context- and/or Tabbrowser-Extension.

My provider has a problem with the internetconnection (VERY very slow)
I opened some group-bookmarks (two times) with 3 bookmarks.
After waiting a few seconds and nothing else happens, I closed the tabs.
Mozilla crashes when closing these tabs. (Talkback ID : TB10088316M)
This crash was not reproducable after deinstalling the Context- and
Tabbrowser-Extension. And producable after installing the Tabbrowser- AND
Context-Extension.
Sorry, the old bugzilla-interface automaticly added some extra information.

Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.1) Gecko/20020826

I'm not contactable for the next days.
GlobalWindowImpl::GetScrollInfo
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 5005]
GlobalWindowImpl::GetScrollY
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 1863]
GlobalWindowImpl::GetPageYOffset
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 1830]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_GetterSetter
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1299]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 840]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 931]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2526]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2624]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 856]
nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1195]
nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 430]
PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 117]
SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 139]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1275]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1485]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 763]
nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2614]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3453]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3446]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6113]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6031]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2098]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1909]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5127]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5382]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3834]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1304]
USER32.DLL + 0x3eb0 (0x77e13eb0)
USER32.DLL + 0x401a (0x77e1401a)
USER32.DLL + 0x92da (0x77e192da)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1534]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1881]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1899]
WinMainCRTStartup()
KERNEL32.DLL + 0x7903 (0x77e87903) 
Assignee: sgehani → jst
Component: XP Apps → DOM Core
Keywords: crash
QA Contact: paw → stummala
Summary: crash when closing tabs with additional XUL-applications → crash when closing tabs with additional XUL-applications [@ GlobalWindowImpl::GetScrollInfo]
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs
I can not reproduce this bug.
The stack seems to be the same as bug 155681.


*** This bug has been marked as a duplicate of 155681 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Component: DOM: Core → DOM: Core & HTML
QA Contact: stummala → general
Crash Signature: [@ GlobalWindowImpl::GetScrollInfo]
You need to log in before you can comment on or make changes to this bug.