Closed Bug 1656903 Opened 2 years ago Closed 2 years ago

Primary password prompt needs to be cancelled twice after restart

Categories

(Toolkit :: Password Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 + verified
firefox81 --- verified

People

(Reporter: ciprian_georgiu, Assigned: severin)

References

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

Affected versions

  • latest Nightly 81.0a1
  • Beta 80.0b3

Affected platforms

  • macOS 10.14
  • Ubuntu 18.04 x64
  • Windows 10 x64

Steps to reproduce

  1. Launch Firefox.
  2. Access https://www.facebook.com/ in a new tab.
  3. Save a set of credentials for this site.
  4. Go to about:preferences#privacy and set a primary password, then restart the browser.
  5. Access again https://www.facebook.com/.
  6. Click on the "Cancel" button from the primary password prompt.

Expected result

  • The primary password prompt is dismissed.

Actual result

  • The primary password prompt is shown again.

Regression range

  • The issue seems to be a regression as I cannot reproduce this on Fx79.0. I will follow-up with a regression range asap.

Additional notes

  • I suggest marking this issue with a S3 priority.
See Also: → 1636578

Needinfo for the regression range as we probably need to fix this in beta.

Flags: needinfo?(ciprian.georgiu)

Last good revision: c34351a5fd6c6bfb76ffd7b86b8757d6d95b581c (2020-07-30)
First bad revision: 161920b70ae464ae0157139327c2d2d7b0480275 (2020-07-31)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c34351a5fd6c6bfb76ffd7b86b8757d6d95b581c&tochange=161920b70ae464ae0157139327c2d2d7b0480275

Severity: -- → S3
Has Regression Range: --- → yes
Priority: -- → P2

Thanks :severin for helping me out with the regression rage. I checked again on the other platforms, Windows and Ubuntu, and it seems that I was wrong initially, the issue can be reproduced there as well. I'll make the proper adjustments to the bug.

Flags: needinfo?(ciprian.georgiu)
OS: macOS → All
Summary: [macOS] Primary password prompt needs to be cancel twice after restart → Primary password prompt needs to be cancel twice after restart
Duplicate of this bug: 1658290
Assignee: nobody → severin.mozilla
Status: NEW → ASSIGNED

Alice, does the problem still happen on the latest Nightly and can you confirm the regression range since it seems different than bug 1658290 comment 0?

Flags: qe-verify+
Flags: needinfo?(alice0775)
Summary: Primary password prompt needs to be cancel twice after restart → Primary password prompt needs to be cancelled twice after restart

(In reply to Matthew N. [:MattN] from comment #6)

Alice, does the problem still happen on the latest Nightly and can you confirm the regression range since it seems different than bug 1658290 comment 0?

I cannot reproduce the issue on Nightly81.0a1(20200811214738) Windows10 with STR of this BUG(Bug 1656903 comment 0).
However I can still reproduce the issue with STR of Bug 1658290 comment 0.

Flags: needinfo?(alice0775)

Hi Alice, sorry for bothering you again about this issue. I can't reproduce this anymore regardless if I am using STR from this Bug or Bug 1658290 on the latest Nightly (2020-08-12) on Windows 10 and MacOS 10.13. Can you give it another shot? I also asked Ciprian about this to check it out.

If you can reproduce it, toggle the following preference "signon.backup.enabled" to "false" and check it out again. That pref is expected to fix this but I can't confirm that since I can't reproduce this anymore.

Flags: needinfo?(alice0775)

I can confirm that the issue doesn't reproduce anymore by following the steps from comment 0. I checked on latest Nightly 81.0a1 (20200812034418) under macOS 10.14 and Win 10 x64.

(In reply to Timea Cernea [:tbabos] from comment #8)

Hi Alice, sorry for bothering you again about this issue. I can't reproduce this anymore regardless if I am using STR from this Bug or Bug 1658290 on the latest Nightly (2020-08-12) on Windows 10 and MacOS 10.13. Can you give it another shot? I also asked Ciprian about this to check it out.

Reproduced With STR Bug 1658290 comment 0: Screenshot https://youtu.be/LXL9vONxL98 .

If you can reproduce it, toggle the following preference "signon.backup.enabled" to "false" and check it out again. That pref is expected to fix this but I can't confirm that since I can't reproduce this anymore.

And Setting signon.backup.enabled to false, still reproduced.

Flags: needinfo?(alice0775)

That was extremely helpfull, thank you very much. I was not using explicitly the url you provided in Bug 1658290 but the main page of Bugzilla. Can you reproduce this with other pages, maybe Facebook's login form?

Attaching Log for when the issue is reproduced. Setting "signon.backup.enabled" does indeed not fix this issue.

Flags: needinfo?(alice0775)

(In reply to Timea Cernea [:tbabos] from comment #11)

Can you reproduce this with other pages, maybe Facebook's login form?

I've tried facebook, gmail, twitter, wikipedia, and github login pages, but I haven't succeeded in reproducing the issue yet.

Flags: needinfo?(alice0775)
Attachment #9169533 - Attachment is obsolete: true
Attached file Uplift request for Bug 1656903 (obsolete) —

Approval Request Comment
[Feature/Bug causing the regression]: bug 1593467
[User impact if declined]: users on certain pages will get prompts for Primary Password multiple times, potentially having to click cancel several times before continuing to browse
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: yes, same STR as listed in bug 1656903
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: it is a reversion of a previous, very minor change
[String changes made/needed]: none

Attachment #9169682 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Verified-fixed on the latest Nightly 81.0a1 (2020-08-13) on Windows 10, MacOS 10.13 and Ubuntu 18.04 by following the steps in Bug 1658290.
Please not this fix and verification works for sites with multiple forms on the same page, such as: https://bugzilla.mozilla.org/enter_bug.cgi?format=__default.

Waiting for Uplift to Beta 80.

Comment on attachment 9169674 [details]
Bug 1656903 - partial reversion of 1593467;r=MattN

fix for primary password prompts, approved for 80.0b8.

note you can request uplift on the original attachment/patch, no need for a new one.

Attachment #9169674 - Flags: approval-mozilla-beta+
Attachment #9169682 - Flags: approval-mozilla-beta?
Attachment #9169682 - Attachment is obsolete: true

Verified-fixed on latest Beta 80.0b8 on Windows 10, MacOS 10.13 and Ubuntu 18.04

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.