Closed Bug 1656999 Opened 4 months ago Closed 4 months ago

Perma TEST-UNEXPECTED-PASS | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | fail-if condition in manifest - We expected at least one failure

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jgilbert, NeedInfo)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file, 1 obsolete file)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=311912828&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/bSgk1ht1TSeojTbt9uKHgg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-08-03T19:13:10.753Z] 19:13:10 INFO - TEST-START | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html
[task 2020-08-03T19:13:10.931Z] 19:13:10 INFO - Buffered messages logged at 19:13:10
[task 2020-08-03T19:13:10.932Z] 19:13:10 INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | A valid string reason is expected
[task 2020-08-03T19:13:10.933Z] 19:13:10 INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | Reason cannot be empty
[task 2020-08-03T19:13:10.934Z] 19:13:10 INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | should be green
[task 2020-08-03T19:13:10.944Z] 19:13:10 INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | successfullyParsed is true
[task 2020-08-03T19:13:10.945Z] 19:13:10 INFO - Buffered messages finished
[task 2020-08-03T19:13:10.945Z] 19:13:10 INFO - TEST-UNEXPECTED-PASS | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | fail-if condition in manifest - We expected at least one failure
[task 2020-08-03T19:13:10.951Z] 19:13:10 INFO - TEST-INFO | expected FAIL
[task 2020-08-03T19:13:10.951Z] 19:13:10 INFO - GECKO(1271) | MEMORY STAT | vsize 2775MB | residentFast 213MB | heapAllocated 29MB
[task 2020-08-03T19:13:10.963Z] 19:13:10 INFO - TEST-OK | dom/canvas/test/webgl-conf/generated/test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html | took 214ms

This failure has started permafailing once Bug 1616925 has landed.
Based on the Element conversation, this bug ^ caused the docker images to be rebuilt, and backing out would have switched back to the older image, so the tests would go back to expected fail, instead of unexpected pass.

Flags: needinfo?(tom)

Jeff, can you take care of updating the expectations for these unexpected passes, please?

Flags: needinfo?(jgilbert)

It feels really unfair that I have always gotten backed out for these exact issues.
I'm fine with that changing, but I expect to be given the same latitude in the future.

Flags: needinfo?(jgilbert)
Assignee: nobody → csabou
Status: NEW → ASSIGNED
Attachment #9167966 - Attachment description: Bug 1656999 - Set test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html to pass of linux. r=jgilbert → Bug 1656999 - Set test_2_conformance2__glsl3__matrix-row-major-dynamic-indexing.html to pass on linux. r=jgilbert
Attachment #9167966 - Attachment is obsolete: true
Assignee: csabou → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 1657027

Some tests now pass after rebuilding Docker images in bug 1616925.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Assignee: nobody → jgilbert
You need to log in before you can comment on or make changes to this bug.