Chat text is being written into a wrong place.

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
16 years ago
2 months ago

People

(Reporter: sammy, Unassigned)

Tracking

({qawanted})

Trunk
x86
All
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
When joined a chat the text written by others is being written to wrong place.

The www-pages are written in finnish, but trying this should be easy if you
don't understand finnish.

I don't know if the parser is the component where the fault is.
What are the exact steps to join the chat?
Assignee: harishd → attinasi
Component: Parser → Layout
QA Contact: moied → petersen
Summary: Chat text is being written into a wrong place. → Chat text is being written into a wrong place.
(Reporter)

Comment 2

16 years ago
Steps to join the chat:

1. Click in the picture the chat room you want to use. (Any will do)

2. Next you are shown the people using this place. A room with a few users
should be selected. If there are no users or you see text "TÄYNNÄ" (which means
that the channel has maximum number of users), you should go to the step one and
select other chat room.

3. Enter your alias (any unused alias will do)

4. There is a link called "sisään" just below the alias field. Click it to join
the chat.

5. Now you have joined the chat. And text by other users is written in the wrong
place (-> to the window where you should enter the text).

Updated

16 years ago
QA Contact: petersen → moied
Created attachment 99323 [details]
What I see when I follow those directions

This seems to be ok, no?
(Reporter)

Comment 4

16 years ago
Created attachment 99332 [details]
Picture when chatting with mozilla browser

Chatting with multiple users, the screenshot of my Mozilla. I am using 1.0, but
also with 1.1 I am having the same problem.
(Reporter)

Comment 5

16 years ago
A screenshot attached to this bug report in 2002-09-15 21:15 seems perfectly ok.
But this migh be because there is only one person in the chat room. I attached a
screenshot what I see when joining a chat room, where there are multiple users.
Sami, 1.1 is pretty old at this point (and 1.0 is _very_ old).  Could you test 1.2a?
(Reporter)

Comment 7

16 years ago
Created attachment 99360 [details]
Mozilla 1.2a showing the same bug as previous versions.

Same bug exists in mozilla 1.2 alpha.

Comment 8

16 years ago
reporter (Sami): can you still reproduce this bug with a recent build of mozilla
(for example, 1.2.1)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 9

16 years ago
I just reproduced this bug with mozilla 1.2.1. 1.2.1 behaves like previous versions.
I am able to reproduce this issue with a recent nightly trunk build (Mozilla/5.0
(Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207). But not
consistently, sometimes it works OK.

The chat server functions by letting the actual chat page (the topmost frame
with text on white background) be 'neverending', i.e. the page never finishes
loading. New HTML content is written to the TCP stream as the chat participants
produce new dialogue.

For some reason (I'm not sure if Mozilla or the chat server is here to be
blamed), Mozilla mixes up the data streams of the top frame (dynamic,
neverending page) and the bottom frame (static page) by appending the new chat
dialogue to the bottom frame, where it does not belong.

I first susptected something along a HTTP pipelining or HTTP/1.1 vs. HTTP/1.0
issue, but changing settings in the preferences does not seem to change behaviour.
(Reporter)

Comment 11

16 years ago
Bug still exists in Mozilla 1.3.
Over to browser-general for triage; this is not sounding much like layout.
Assignee: attinasi → asa
Component: Layout → Browser-General
Keywords: qawanted
QA Contact: moied → asa

Comment 13

16 years ago
Created attachment 125019 [details]
Screen shot of chat room

Comment 14

16 years ago
This worked fine for me.

	
Mozilla 1.4
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030529
(Reporter)

Comment 15

16 years ago
I tried mozilla 1.4rc1, still did not work.

Comment 16

15 years ago
Sami, can you test this with 1.6 or newer? I'm unable to reprduce a problem with
a nightly build from 2004020308. Please re-open if you can still reproduce this
on 1.6 or newer. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

15 years ago
I tested with mozilla 1.6 and with mozilla's latest nightbuild, the bug remains
in them both.

In addition to Opera, konqueror also seems to work correctly.

In addition to mozilla, epiphany, galeon and mozilla-firebird 0.7 do not work
correctly.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Sami, are you using a clean profile?
(Reporter)

Comment 19

15 years ago
I just tried with a clean profile (mozilla 1.6). Bug still remains.

I bet that this might be unpleasant to test for person who does not speak
finnish. Let me translate some buttons:

"Sano" button means "Say"
"Poistu" buttons means "Leave"
"sanot" is translated as "you say"
"kaikille" is translated as "for all" 

If needed, I can provide more translations.

Comment 20

15 years ago
I see this also:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8

Opened up Mozilla 1.6, logged in and sent a message to the same room. In
Firefox, the message from Mozilla goes to the lower part of the screen, where ya
enter yer message to send it out.

Comment 21

15 years ago
*** Bug 196409 has been marked as a duplicate of this bug. ***

Comment 22

15 years ago
->frames
Assignee: asa → nobody
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: HTML Frames
Ever confirmed: true
QA Contact: asa → core.layout.html-frames
This bug needs a minimal testcase.  Until we have one, there's no point looking
at it, really...
And Asa, _please_ stop confirming layout bugs without testcases.  They'll never
be looked at, and being confirmed means they will never get a testcase either.

Comment 25

14 years ago
I see not one problem. Everything checks out OK.

Comment 26

7 years ago
site goes to http://www.voice.fi/
so testcase URL is gone
Status: NEW → RESOLVED
Last Resolved: 15 years ago7 years ago
Resolution: --- → INCOMPLETE

Updated

2 months ago
Product: Core → Core Graveyard
(Assignee)

Updated

2 months ago
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.