Closed Bug 1657097 Opened 6 months ago Closed 6 months ago

Stop running all builds on autoland

Categories

(Firefox Build System :: Task Configuration, enhancement)

enhancement

Tracking

(firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: marco, Assigned: marco)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We are running all builds on autoland to speed-up backfills.

In the past few months, we have landed a lot of improvements to build times, and we have stopped using shippable on autoland in favor of opt.
This all means the additional delay of builds is not as significant as before.

I think it'd be preferable not to run all builds, but only those required by the tests selected to run, and automatically trigger builds when backfills are requested.

This would probably be a considerable saving.

Component: General → Task Configuration
Product: Firefox → Firefox Build System
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Attachment #9168083 - Attachment description: Bug 1657097 - Stop running all builds on autoland, only run builds selected by bugbug and builds that are dependencies of test tasks. r=ahal,jmaher,aryx → Bug 1657097 - Stop running all builds on autoland, only run builds selected by bugbug and builds that are dependencies of test tasks. r=ahal!,jmaher,aryx
Pushed by mcastelluccio@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3011872aa773
Stop running all builds on autoland, only run builds selected by bugbug and builds that are dependencies of test tasks. r=ahal,jmaher

This is also going to cause issues for mozregression, right? i.e. We may not be able to fully bisect within a given autoland range anymore due to not having a complete set of builds for whatever platform we happen to be bisecting on?

Flags: needinfo?(mcastelluccio)

We are still running many builds by default (probably because of some non-test tasks dependent on them).

(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)

This is also going to cause issues for mozregression, right? i.e. We may not be able to fully bisect within a given autoland range anymore due to not having a complete set of builds for whatever platform we happen to be bisecting on?

Yes, I was assuming when you go down to autoland the choice between possible culprits is already small enough. Do you think this drawback is not acceptable? If so, are there some builds that should always be there?

Flags: needinfo?(mcastelluccio)

If we're still getting the shippable builds on every push, that's probably enough for the most part. Debug builds would also be nice, but probably not as critical.

(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)

If we're still getting the shippable builds on every push, that's probably enough for the most part. Debug builds would also be nice, but probably not as critical.

Do you mean opt? Shippable builds were removed from autoland in bug 1650208.

As long as mozregression can still find the opt builds, they should be fine. While it's not outside the realm of possibility for a PGO-only issue to arise, that seems low enough risk to accept.

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
See Also: → 1657856

(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)

As long as mozregression can still find the opt builds, they should be fine. While it's not outside the realm of possibility for a PGO-only issue to arise, that seems low enough risk to accept.

I pinged the mozregression people and they said that it will fallback to opt if it can't find shippable.

You need to log in before you can comment on or make changes to this bug.