Closed Bug 1657147 Opened 2 years ago Closed 2 years ago

"Make Firefox Nightly default" is displayed as-cut off inside the windows toast notification

Categories

(Toolkit :: Default Browser Agent, defect, P2)

Firefox 81
All
Windows 10
defect

Tracking

()

VERIFIED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- verified
firefox82 --- verified

People

(Reporter: emilghitta, Assigned: bytesized)

References

Details

Attachments

(3 files)

Attached image MakeFirefoxNightly.png

Affected versions

  • 81.0a1 (BuildId:20200727203201)

Unaffected versions

  • 80.0b3 (BuildId:20200803045446)
  • 79.0 (BuildId:20200720193547)
  • 78.1.0esr (BuildId:20200722151235)
  • 68.11.0esr (BuildId:20200720181548)

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • Ubuntu 18.04 64bit
  • macOS 10.14

Steps to reproduce

  1. Launch Firefox Nightly.
  2. Access the about:preferences page and make Firefox Nightly the default browser.
  3. Set date and time to reflect a 24hr period from now.
  4. Open Microsoft Edge and set it as the default browser.
  5. Set date and time to reflect a 24hr period from now.
  6. Observe the toast notification.

Expected result

  • The toast notification is displayed without any UI issues.

Actual result

  • The “Make Firefox Nightly default” is displayed as cut-off.

Regression Range

  • I don’t think that this is a regression.

Notes

  • Please observe the attached screenshot for further information regarding this issue.
  • These seems to affect only Firefox Nightly builds.
  • [Suggested Severity] Since this is a cosmetic issue I think that S4 fits for this one.
Group: mozilla-employee-confidential
Severity: -- → S3
Priority: -- → P2

Kirk,

Since the headline already reads `Switch back to Firefox Nightly?' what do you think about just changing the button text to 'Make Nightly default' instead?

Flags: needinfo?(ksteuber)

That sounds fine display-wise, but from an implementation perspective I'm unsure. I would really rather not end up with code looking like:

if (name == "Firefox Nightly"):
   name = "Nightly"

Looking through the codebase, there is a value around called "brand shortname", which seems to be what we want here (contains "Nightly" rather than "Firefox Nightly"). But I can't figure out if there is any way to access this value from generate_ini.py, which is where we would need it.

@Pike - Perhaps you know if there is some way to access the "brand shortname" from generate_ini.py?

Flags: needinfo?(ksteuber) → needinfo?(l10n)

There's not, and AFAICT, https://searchfox.org/mozilla-central/source/browser/branding/nightly/configure.sh is the thing exposing that to the build toolchain, and that doesn't have anything else.

Also, https://searchfox.org/mozilla-central/source/browser/branding/aurora/configure.sh is gonna make your problem worse :-/ .

Flags: needinfo?(l10n)

This feature is no longer confidential.

Group: mozilla-employee-confidential

Kirk just brought up a good point in that we're going to have the same problem for DevEdition except that there's no shorthand for that channel that's going to work here. I think we should be ok for beta since the brand name IIRC is "Firefox" but probably good to confirm there just in case.

One option would be for those channels only (where the brand name is not simply "Firefox") to just swap the text to something generic like "Yes, switch back" instead of "Make Firefox default" (For context the top level headline reads 'Switch back to Firefox Nightly?').

Romain, are you good with us moving forward in this direction? Feels like the simplest thing to do for now since it'd be good to get this fixed relatively quickly as it's out in production.

Flags: needinfo?(rtestard)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Notifications and Alerts

(In reply to Rachel Tublitz [:rachel] from comment #5)

Kirk just brought up a good point in that we're going to have the same problem for DevEdition except that there's no shorthand for that channel that's going to work here. I think we should be ok for beta since the brand name IIRC is "Firefox" but probably good to confirm there just in case.

One option would be for those channels only (where the brand name is not simply "Firefox") to just swap the text to something generic like "Yes, switch back" instead of "Make Firefox default" (For context the top level headline reads 'Switch back to Firefox Nightly?').

Romain, are you good with us moving forward in this direction? Feels like the simplest thing to do for now since it'd be good to get this fixed relatively quickly as it's out in production.

Yes, sounds like a great call

Flags: needinfo?(rtestard)
Attached image deved.png
Has STR: --- → yes
Assignee: nobody → ksteuber
Status: NEW → ASSIGNED
Pushed by ksteuber@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ff945bee48a9
Shorten WDBA notification button text to prevent overflows r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch

The patch landed in nightly and beta is affected.
:bytesized, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(ksteuber)
Flags: needinfo?(ksteuber)

Comment on attachment 9171827 [details]
Bug 1657147 - Shorten WDBA notification button text to prevent overflows r=mhowell

Beta/Release Uplift Approval Request

  • User impact if declined: Users on Nightly and Developer edition that see the WDBA notification will see cut off text in one button, as shown in this bug's description.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not very risky. Patch only contains a string change, and the string is not localized.
  • String changes made/needed: Non localized string change of button text in WDBA notification.
Attachment #9171827 - Flags: approval-mozilla-beta?

Comment on attachment 9171827 [details]
Bug 1657147 - Shorten WDBA notification button text to prevent overflows r=mhowell

Approved for 81.0b4.

Attachment #9171827 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Verified on Firefox 82.0a1 (2020-09-09) and DevEdition 81.0b8 under Windows 10 and the message is changed to "Yes, switch back".

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Notifications and Alerts → Default Browser Agent
You need to log in before you can comment on or make changes to this bug.