Locks at splash screen

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Mike Mills, Assigned: asa)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If I do a complete install, mozilla locks on the first execution - displays the
splash screen and stops there.  It does not appear in the Task Manager
Applications listing, but rather you must end the task in the Processes listing.

This same behavior was observed using 1.0 and 1.1b

If I uninstall and reinstall only the browser and security manager, it seems to
work fine.

Comment 1

16 years ago
Did you ever install (a newer) Mozilla in an existing Mozilla directory?

if so: please remove your Mozilla directory (the settings are stored somewhere
else) and try reinstall Mozilla.

Comment 2

16 years ago
Same here. Apparently, uninstalling and re-installing makes the browser re-
usable, but only once. After closing the browser the procedure must be re-
enacted. A bug in all versions I've tried so far, which is from 1.0 RC1 -> 1.1.

Only viable solution I've found is to not only uninstall and remove the 
directory in the Program Files folder, but also remove all references to the 
word "Mozilla" in the registry.

Running Windows XP. It seems that the problems MAY be tied to the Java plug-in, 
the problems came (twice) after I started to install that one.

Updated

16 years ago
Severity: blocker → critical
Keywords: hang
(Reporter)

Comment 3

16 years ago
OK guys - thanks for all your help on this matter.  

Here is what I did:

I copied the bookmarks.html file from c:/documents and 
settings/myname/application data/mozilla/profiles/default/blargblarg.slt to my 
desktop for safekeeping, then uninstalled mozilla, deleted the c:/documents and 
settings/myname/application data/mozilla folder, and also deleted the 
d:/program files/mozilla.org folder.  

Then I reinstalled to d:/program files/mozilla.org selecting complete install

Everything works fine, I had to reconfigure the browser and re-install the 
Little Mozilla theme, but once I copied the bookmarks back into the proper 
folder, everything else worked fine.

Thanks guys!

Do we leave this bug as outstanding or is there a way to mark it 'known with a 
workaround'?

Comment 4

16 years ago
Thanks for the info.

I tried the same, but in an attempt to narrow down the problem, I did NOT 
remove the c:\program files\mozilla.org folder and then I reinstalled. Works 
fine now. Thus, it seems that the bug can be tracked to the c:/documents and 
settings/myname/application data/mozilla folder.

Comment 5

16 years ago
from previous comments, this bug seems to have gone away in this case.

sounds like the chrome files in the browser and/or profile got screwed up by
installing multiple versions and/or themes. certainly a known issue that it
doesn't work when it gets screwed up, the problem is identifying what causes it
to get screwed up in the first place...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.