Closed Bug 1657317 Opened 2 years ago Closed 2 years ago

[mac] Cursor position is offset after renaming a profile in about:profiles page

Categories

(Core :: Panning and Zooming, defect, P3)

Desktop
macOS
defect

Tracking

()

VERIFIED DUPLICATE of bug 1657627

People

(Reporter: csasca, Assigned: kats)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached video cursor offset.mov

Affected versions

  • Firefox 80.0b4
  • Firefox 81.0a1

Affected platforms

  • macOS 10.15.6

Steps to reproduce

  1. Launch Firefox
  2. Access about:profiles
  3. Click on rename on the last profile
  4. Edit it and select OK.

Expected result

  • The cursor's position is not modified

Actual result

  • The cursor's real position is offset

Regression range

  • Will see for a regression.

Additional notes

  • The issue can be seen in the attachment
  • This may be not reproducible if there are more or less profiles available in the page.
  • This was reproduced on a retina display with "more space" setting active and 4 profiles in the page.
  • The issue's severity: S3-S4
Has Regression Range: --- → no
Has STR: --- → yes
Severity: normal → --

Unfortunately, I have no luck to reproduce this issue by following the steps with 4 profiles in the Firefox 68.11.0esr, 79(Release), 80.0b8(Beta), 81.0a1(Nightly) in macOS 10.15.6. My cursor's position is not modified.

Severity: -- → S4

:csasca, could you try to find a regression-window if you could reproduce this consistently? Thanks.

Flags: needinfo?(catalin.sasca)

Hey Edgar, the bisecting got me this info
2020-08-18T12:51:27.280000: DEBUG : Found commit message:
Bug 1644271 - Enable the MVM pref by default. r=tnikkel

Differential Revision: https://phabricator.services.mozilla.com/D79230

2020-08-18T12:51:27.280000: DEBUG : Did not find a branch, checking all integration branches
2020-08-18T12:51:27.282000: INFO : The bisection is done.
2020-08-18T12:51:27.283000: INFO : Stopped

This seems to be somewhere between 2020-06-11 and 2020-06-12

And builds info
build_url: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/W4i4wLjTQmywqXH0Zexs1Q/runs/0/artifacts/public%2Fbuild%2Ftarget.dmg
changeset: 61fccfec51e98f51d9865bf1ff5808016a948a71
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=61fccfec51e98f51d9865bf1ff5808016a948a71&tochange=01a1753056cfcc36972d43791d0f6fe43a502480
repo_name: autoland
repo_url: https://hg.mozilla.org/integration/autoland
task_id: W4i4wLjTQmywqXH0Zexs1Q

On the affected builds, the page stays still after renaming a profile, where as on a unaffected build, the page scrolls back to top, and resets mouse position as well I think. Hope this helps, please let me know if I can help any further.

Flags: needinfo?(catalin.sasca)

Hi Kartikaya, per comment #3, this looks like a regression of Bug 1644271, look like similar to bug 1650977 and bug 1657627? Thanks.

Flags: needinfo?(kats)
Severity: S4 → --
See Also: → 1657627, 1650977

Thanks, and yes, it is probably the same issue as the other regressions of bug 1644271. I landed a fix for non-nightly channel already, and am waiting on some dependencies to be able to fix it in Nightly. I can park the bug with me for now and verify once I have the fix.

Assignee: nobody → kats
Component: DOM: UI Events & Focus Handling → Panning and Zooming
Flags: needinfo?(kats)
Severity: -- → S2
Priority: -- → P3

I'm going to use bug 1657627 as the canonical one to track this problem, but will verify this bug as well once the fix is landed.

Status: NEW → RESOLVED
Has Regression Range: no → yes
Closed: 2 years ago
Regressed by: 1644271
Resolution: --- → DUPLICATE
See Also: 1657627, 1650977
Duplicate of bug: 1657627
Keywords: regression

I wasn't actually able to reproduce the problem, maybe because I have a different number of profiles. But all the other regressions that were similar to this one are now fixed, and I expect this one should be as well. Can you please retest on the latest nightly to verify?

Flags: needinfo?(catalin.sasca)

Hi Kartikaya, sorry for the late response. I was in PTO.

So I tried reproducing this on Firefox 82.0a1 (2020-09-08) and Firefox 81.0b8 under macOS 11 and the cursor issue is fixed. We can safely close this issue now. Thank you and sorry again for the late response.

Flags: needinfo?(catalin.sasca) → needinfo?(kats)

Great, thank you!

Status: RESOLVED → VERIFIED
Flags: needinfo?(kats)
You need to log in before you can comment on or make changes to this bug.