Layout broken using images align="left".

RESOLVED DUPLICATE of bug 109849

Status

()

RESOLVED DUPLICATE of bug 109849
17 years ago
17 years ago

People

(Reporter: m.polat, Assigned: attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-AT; rv:1.1) Gecko/20020826

The middle column gets expanded, but it should be like on this page, mozilla is
showing correct:
http://fhh.hamburg.de/coremedia/generator/Aktuell/behoerden/start.html

The Problem are the Pictures in the middle column aligned left. By deleting or
aligning them right, the layout is OK. The same Problem was on this Page:
http://www.hamburg.de/fhh/behoerden/staatsarchiv/link_to_your_roots/ackermann.htm
The picture in the middle column is in a table and the table was aligned left.
When aligining the table Left, the Layout crashes. When aligning right, its OK.

Reproducible: Always

Steps to Reproduce:
1. Open Page http://fhh.hamburg.de/coremedia/generator/Aktuell/
2.
3.

Actual Results:  
The Layout crashes

Expected Results:  
Mozilla should break the Text, and not exceed the middle column.

Comment 1

17 years ago
please try to file browser bugs in the browser product...
Assignee: justdave → attinasi
Component: bugzilla.org → Layout
Product: Bugzilla → Browser
QA Contact: matty → petersen
Version: unspecified → other

Comment 2

17 years ago
Dupe of bug 109849? 
Summary: Layout crashes using images align="left". → Layout broken using images align="left".

Comment 3

17 years ago
I think it is.  THe code causing the problem is:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
 <HEAD>
  <BASE href="http://fhh.hamburg.de/coremedia/generator/Aktuell/">
 </HEAD>
 <BODY BGCOLOR="#FFFFFF" MARGINHEIGHT="5" TOPMARGIN="5" MARGINWIDTH="0"
LEFTMARGIN="0">
  <TABLE BGCOLOR="#FFFFFF" WIDTH="390" CELLSPACING="0" CELLPADDING="0" BORDER="1">
   <TR>
    <TD WIDTH="390" VALIGN="top" ALIGN="left" CLASS="text">
     <P CLASS=text>
      <IMG
SRC="aktuelle-meldungen/zz-stammdaten/bilddaten/elbfischer,property=inline.jpg"
WIDTH="100" HEIGHT="134" ALIGN=LEFT VSPACE="5" BORDER="0" ALT="">
      <IMG HEIGHT="134" ALIGN=LEFT
SRC="/coremedia/generator/System/Bilder/no,property=source.gif" WIDTH="5"
BORDER="0" VSPACE="5">
      <B>Ausstellung im Rathaus: Finkenwerder  vom Fischfang zur Industrie</B>
     </P>
     <P CLASS="bild-zentriert">
      <IMG
SRC="/coremedia/generator/Aktuell/aktuelle-meldungen/zz-stammdaten/bilddaten/linie-350x15,property=original.gif"
WIDTH="350" HEIGHT="15" BORDER="0" ALT="">
     </P>
    </TD>
   </TR>
  </TABLE>
  <DIV style="position: absolute; top: 0; left: 0; width: 390px; border: 1px
solid red; height: 250px;"> </DIV>
 </BODY>
</HTML>

Basically, I think it is wrapping the "line" image onto the next line, but still
calculating the width as the float plus the line image, just like bug 109849.

*** This bug has been marked as a duplicate of 109849 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: petersen → moied
You need to log in before you can comment on or make changes to this bug.