Closed Bug 1657545 Opened 6 months ago Closed 6 months ago

Fix -Wbackslash-newline-escape warning in gfx/wr/swgl/src/gl.cc

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

clang -Wbackslash-newline-escape warning in gfx/wr/swgl/src/gl.cc:

Compiling swgl v0.1.0 (/Users/chris/Code/mozilla/firefox/gfx/wr/swgl)
warning: src/gl.cc:413:81: warning: backslash and newline separated by space [-Wbackslash-newline-escape]
warning:   macro(GL_ZERO, GL_ONE_MINUS_SRC_ALPHA, 0, 0)                                 \
warning:                                                                                 ^
warning: 1 warning generated.

Regressed by clang format gl.cc bug 1656813. This whitespace issue wasn't reported or fixed by clang-format because it's in a clang-format off block.

https://hg.mozilla.org/mozilla-central/rev/d32a631ca7b8e3788645c76740c475ec824d6d41

Compiling swgl v0.1.0 (/Users/chris/Code/mozilla/firefox/gfx/wr/swgl)
warning: src/gl.cc:413:81: warning: backslash and newline separated by space [-Wbackslash-newline-escape]
warning: macro(GL_ZERO, GL_ONE_MINUS_SRC_ALPHA, 0, 0)
warning: ^
warning: 1 warning generated.

Regressed by bug 1656813

Pushed by cpeterson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/035c613821c6
Fix -Wbackslash-newline-escape warning in gfx/wr/swgl/src/gl.cc. r=mattwoodrow
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.