Open Bug 1657569 Opened 2 years ago Updated 2 years ago

Web developer tools menu doesn't use any of the related icons

Categories

(DevTools :: General, defect, P5)

defect

Tracking

(firefox79 wontfix, firefox80 wontfix, firefox81 affected)

Tracking Status
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- affected

People

(Reporter: csasca, Unassigned)

Details

Attachments

(1 file)

Affected versions

  • Firefox 80.0b4
  • Firefox 81.0a1

Affected platforms

  • macOS 10.15.6
  • Windows 7
  • Ubuntu 18.04

Steps to reproduce

  1. Launch Firefox
  2. Access customize
  3. Drag Web Developer tools in the toolbar
  4. Open the Web Developer tools

Expected result

  • The list starts from the left side of the menu

Actual result

  • The list is offset on the right side of the menu

Regression range

  • This is not a recent regression, as it is reproducible on Firefox Nightly (2020-02-02), will see for a regression.

Additional notes

  • The issue can be seen in the attachment
Has Regression Range: --- → no
Has STR: --- → yes
Component: Layout: Generated Content, Lists, and Counters → Menus
Product: Core → Firefox

This is not a bug per-se, it is just that the web developer menu doesn't show any icons for the menuitems. If you click on the Firefox menu you will see the same offset but many of the menuitems there have icons associated with them. We do however have icons for many of the features in the menu, so we should place those icons next to the menuitems to help people find what they're looking for faster if they're used to seeing the icons. I'll change the summary of the bug to reflect this.

This is not a regression, it has been this way since the menu was introduced.

Component: Menus → General
Product: Firefox → DevTools
Summary: Web developer tools menu list is offset → Web developer tools menu doesn't use any of the related icons
Severity: normal → S4
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.