Closed Bug 1657801 Opened 7 months ago Closed 6 months ago

If the current search mode engine is removed, search mode should be cleared

Categories

(Firefox :: Address Bar, task, P2)

task
Points:
2

Tracking

()

VERIFIED FIXED
82 Branch
Iteration:
82.2 - Sep 7 - Sep 20
Tracking Status
firefox82 --- verified

People

(Reporter: adw, Assigned: harry)

References

Details

Attachments

(1 file)

It's possible for the user to remove the engine that's currently used in search mode. We should probably clear search mode in that case -- at least it should no longer use the removed engine.

And this should be fixed per tab. One possible mistake we could make here would be to just set searchMode to null, though once search mode is retained per tab, when going back to a tab we may risk to enter search mode with an invalid engine. Likely when entering search mode we should check the engine is valid, in addition to exiting it for the current tab.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 82.2 - Sep 7 - Sep 20
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/af47bc7c002d
Exit search mode if the current search mode engine is removed. r=adw
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Regressions: 1665036

If a tab is in search mode with a search engine, then I remove that search engine the tab remains in the search mode.
Is this intended?

Flags: needinfo?(htwyford)

No, that's not intended. Can you please check that you're using the latest Nightly and provide a screen recording? Search mode is cleared when an engine is removed on my machine.

Flags: needinfo?(htwyford)
Regressions: 1665123

With the today's nightly I can not reproduce this issue anymore.

Status: RESOLVED → VERIFIED
Regressions: 1667031
You need to log in before you can comment on or make changes to this bug.