Closed Bug 1657811 Opened 2 years ago Closed 2 years ago

battle.wazana.io game loads slowly after starting it

Categories

(Core :: Graphics: Canvas2D, defect, P3)

Other Branch
Unspecified
All
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox80 --- wontfix
firefox81 --- wontfix
firefox82 --- fix-optional

People

(Reporter: cfogel, Unassigned)

References

(Depends on 1 open bug, )

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(1 file)

Affected versions

  • 80.0b4, 81.0a1 (2020-08-06)

Affected platforms

  • Windows 10, macOS 10.15.5;

Steps to reproduce

  1. Launch Firefox and access https://battle.wazana.io/
  2. Try to play the game;
  • pick faction, scroll @map to find rectangles on which to pick your position, after that press Start so the game starts up;

Expected result

  • game is playable;

Actual result

  • go make yourself a coffee, read the news because the loading times are horrible;

Regression range

  • will check and provide info asap;

Additional notes

  • suggested severity is S4 due to this not being the most popular link/game/website.
Has Regression Range: --- → no
Has STR: --- → yes
Summary: battle.wazana.io loads slowly → battle.wazana.io game loads slowly after starting it

Looks like canvas issue. Windows10+Intel HD 5500 mobile iGPU
Without remote canvas: https://share.firefox.dev/2PyY2Hg

Perf is still bad with remote canvas

Attached file about:support
Component: Performance → Canvas: 2D

Chrome is quite smooth on this

Jeff, is this known?

Severity: -- → S3
Flags: needinfo?(jgilbert)
Priority: -- → P3

The game uses fillText and strokeText while the canvas shadow properties are set. So we construct an intermediate DrawTarget to apply the shadow, on every call to fillText/strokeText.

Flags: needinfo?(jgilbert)

Does "depends on bug 1560450" mean, the regressing bug is bug 1468801 ?

Flags: needinfo?(jgilbert)

Probably, but it's not a useful dependency for us here. Bug 1560450 is the core "there was a regression" bug. Most of these bugs could be duped to 1560450, but I want to keep them distinct for now.

Flags: needinfo?(jgilbert)
QA Whiteboard: [qa-regression-triage]

In an attempt to get the regression range, I've noticed a huge improvement in the usability of the game/site.
As reference, the same load timers are on 67.0a1 (2019-03-03) and 78.0a1 (2020-09-20) are similar to other browsers such as Chrome.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.