Closed Bug 1657898 Opened 6 months ago Closed 6 months ago

fenix raptor tests stopped finding target.apk

Categories

(Testing :: Raptor, defect, P1)

Firefox 81
defect

Tracking

(firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: aryx, Assigned: sparky)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

See https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&selectedTaskRun=JUTK74PnQ6CRfMBVq-EQGg.0&searchStr=fenix%2Craptor&tochange=cc8993c8140a06f97b7f91208e608c01c350961b&fromchange=ffca0003560167ec78d8a69d0ebcbb2a0847ca5a

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=312372344&repo=mozilla-central

[task 2020-08-07T11:36:48.471Z] 11:24:41 INFO - Downloading https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/mobile.v2.fenix.nightly.latest.arm64-v8a/artifacts/public/build/arm64-v8a/geckoNightly/target.apk to /builds/task_159679914930638/workspace/build/target.apk
[task 2020-08-07T11:36:48.471Z] 11:24:41 INFO - retry: Calling _download_file with args: (), kwargs: {'url': u'https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/mobile.v2.fenix.nightly.latest.arm64-v8a/artifacts/public/build/arm64-v8a/geckoNightly/target.apk', 'file_name': u'/builds/task_159679914930638/workspace/build/target.apk'}, attempt #1
[task 2020-08-07T11:36:48.471Z] 11:24:41 WARNING - Server returned status 404 HTTP Error 404: Not Found for https://firefox-ci-tc.services.mozilla.com/api/index/v1/task/mobile.v2.fenix.nightly.latest.arm64-v8a/artifacts/public/build/arm64-v8a/geckoNightly/target.apk

The artifact list for the task links to https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/cuH1r-pST6Cghe1Don1HDw/runs/0/artifacts/public/build/arm64-v8a/target.apk which returns a file.

Is this something from https://github.com/mozilla-mobile/fenix/commit/c93a29f89a25bd0dc0f966deebcfa9e52a36aed5 which needs a gecko in-tree change?

Flags: needinfo?(jlorenzo)

It looks like that fenix commit did cause this. It removed the geckoNightly section in the artifact path.

Severity: -- → S1
Priority: -- → P1
Assignee: nobody → gmierz2
Status: NEW → ASSIGNED

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #0)

Is this something from https://github.com/mozilla-mobile/fenix/commit/c93a29f89a25bd0dc0f966deebcfa9e52a36aed5 which needs a gecko in-tree change?

You're absolutely right, it is 😓

(In reply to Greg Mierzwinski [:sparky] from comment #1)

It looks like that fenix commit did cause this. It removed the geckoNightly section in the artifact path.

That's right. I should have remembered the perf tests in the gecko tree. The PR correctly shows some tests had to be updated to take the new path into account[1]. We cannot revert this patch in Fenix. There were some changes outside of this repo and we would have to change them too. Thank you for the quick fix!

[1] https://github.com/mozilla-mobile/fenix/pull/12827/files#diff-c08b569eed33ba5ba61ae98d4a2cc9fcL51

Flags: needinfo?(jlorenzo)
Keywords: regression
Pushed by gmierz2@outlook.com:
https://hg.mozilla.org/integration/autoland/rev/41129afc4f02
Fix fenix artifact paths. r=jlorenzo,tarek
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.