Closed Bug 1658079 Opened 6 months ago Closed 5 months ago

Perma [tier2] win Aarch OSError: [WinError 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher

Categories

(Firefox :: General, defect, P5)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: sfraser)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered])

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=312417248&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/a0UKr_QPQhCAc5h01lk0Ew/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/a0UKr_QPQhCAc5h01lk0Ew/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[fetches 2020-08-07T17:23:28.153Z] finished fetching artifacts
[resource_monitor 2020-08-07T17:23:28.154Z] Resource monitor starting: ['C:/tasks/task_1596820359/fetches/resource-monitor/resource-monitor.exe', '-process', '7240', '-output', 'monitoring/resource-monitor.json']
[fetches 2020-08-07T17:23:28.179Z] removing C:/tasks/task_1596820359/fetches
[fetches 2020-08-07T17:23:28.184Z] finished
Traceback (most recent call last):
File "run-task", line 978, in <module>
sys.exit(main(sys.argv[1:]))
File "run-task", line 955, in main
resource_process = maybe_run_resource_monitoring()
File "run-task", line 719, in maybe_run_resource_monitoring
cwd=os.getcwd())
File "C:\mozilla-build\python3\lib\subprocess.py", line 775, in init
restore_signals, start_new_session)
File "C:\mozilla-build\python3\lib\subprocess.py", line 1178, in _execute_child
startupinfo)
OSError: [WinError 216] This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher
[taskcluster 2020-08-07T17:23:28.248Z] Exit Code: 1
[taskcluster 2020-08-07T17:23:28.248Z] User Time: 0s
[taskcluster 2020-08-07T17:23:28.248Z] Kernel Time: 93.75ms
[taskcluster 2020-08-07T17:23:28.248Z] Wall Time: 2.0526842s
[taskcluster 2020-08-07T17:23:28.248Z] Result: FAILED
[taskcluster 2020-08-07T17:23:28.249Z] === Task Finished ===
[taskcluster 2020-08-07T17:23:28.249Z] Task Duration: 2.0556856s
[taskcluster:error] Uploading error artifact public/monitoring/resource-monitor.json from file monitoring/resource-monitor.json with message "Could not read file 'C:\tasks\task_1596820359\monitoring\resource-monitor.json'", reason "file-missing-on-worker" and expiry 2021-08-07T15:32:38.669Z
[taskcluster:error] TASK FAILURE during artifact upload: file-missing-on-worker: Could not read file 'C:\tasks\task_1596820359\monitoring\resource-monitor.json'
[taskcluster:error] Uploading error artifact public/logs from file logs with message "Could not read directory 'C:\tasks\task_1596820359\logs'", reason "file-missing-on-worker" and expiry 2021-08-07T15:32:38.669Z
[taskcluster:error] TASK FAILURE during artifact upload: file-missing-on-worker: Could not read directory 'C:\tasks\task_1596820359\logs'
[taskcluster:error] Uploading error artifact public/test_info from file build/blobber_upload_dir with message "Could not read directory 'C:\tasks\task_1596820359\build\blobber_upload_dir'", reason "file-missing-on-worker" and expiry 2021-08-07T15:32:38.669Z
[taskcluster:error] TASK FAILURE during artifact upload: file-missing-on-worker: Could not read directory 'C:\tasks\task_1596820359\build\blobber_upload_dir'
[taskcluster 2020-08-07T17:23:28.521Z] Uploading redirect artifact public/logs/live.log to URL https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/a0UKr_QPQhCAc5h01lk0Ew/runs/0/artifacts/public/logs/live_backing.log with mime type "text/plain; charset=utf-8" and expiry 2021-08-07T15:32:38.669Z
[taskcluster:error] exit status 1

This isn't a TC issue. It looks like resource-monitor.exe doesn't run is "not compatible with the version of Windows you're running".

Component: Workers → General
Product: Taskcluster → Firefox

(In reply to Dustin J. Mitchell [:dustin] (he/him) from comment #1)

This isn't a TC issue. It looks like resource-monitor.exe doesn't run is "not compatible with the version of Windows you're running".

Thank you for adjusting that. Might be from bug 1657834? it got backed out but not merged yet.

Regressed by: 1657834
Whiteboard: [retriggered]
Assignee: nobody → sfraser
Status: NEW → ASSIGNED

It looks like Arm support for gosputil is blocked as it depends on github.com/StackExchange/wmi which in turn depends on github.com/go-ole/go-ole which is win32 specific.

I've filed https://github.com/shirou/gopsutil/issues/916 for advice.

Pushed by sfraser@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/347866d71ddb
Disable resource-monitor support for aarch64 workers r=mtabara
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.