Seems to use an old base URL for newly entered URL's, and reports a 404...

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: petter.sundlof, Assigned: gordon)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
As I've illustrated in the image.

I don't if this is a input line problem... it could be. But the thing is - I had
the same problem in the messenger, while trying to load an attached  URL - it
somehow had a OLD URL I entered previously in memory, report that http://x.x
couldn't be found on server y.y.

Ah well.

Using M11 (1999-10-14-13) + MacOS 8.6.

Comment 1

19 years ago
Does this happen every time you want to post a bug-report?
(Reporter)

Comment 2

19 years ago
This is NOT specific to the bug posting thing. It's global, don't matter if I've

tried to post a bug, or read ./

Comment 3

19 years ago
I don't see this at all on linux. There was something similar some time ago which directed a failed host lookup to localhost instead, but that's solved. Maybe Mac specific. Could you give a clear path, like load URL1 then type in URL2 and get 404?
(Reporter)

Comment 4

19 years ago
No, not really... it seems to be quite random. Sort of.

I didn't experience on the win32 build I tested at school.

Comment 5

19 years ago
Great, this will be a nice one to find. Seems to be Mac specific. Someone with
similar experiences? CCing gordon.

Updated

19 years ago
Assignee: gagan → gordon

Comment 6

19 years ago
while gordon gets a chance to investigate this it will be great if you could
help make this bug reproducible. thx.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Reporter)

Comment 7

19 years ago
It happens very often to me, but I can't describe it in a better manner than I

have already done.

Updated

19 years ago
Target Milestone: M12 → M13

Comment 8

19 years ago
if there is work avaiable to checkin for m12 let me know, else m13.

Comment 9

19 years ago
Bulk move of all Networking-Core (to be deleted component) bugs to new
Networking component.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

19 years ago
I don't see this problem, anymore.  I'm marking it works for me.  Odd, let me
know if you still see this.  If you have anymore information on how to reproduce
it, that would be great.
(Reporter)

Comment 11

19 years ago
I haven't seen it in the most recent nightly builds.

Comment 12

19 years ago
verified:
Mac 2000020708
Status: RESOLVED → VERIFIED

Comment 13

17 years ago
i have seen this bug in mozilla from 0.9.5 to 0.9.8, compiled from freebsd
ports.  here is a thread from freebsd-questions list discussing it...

  mozilla does irrelevant search instead revisiting page
  http://groups.google.com/groups?hl=en&lr=lang_en&th=f06f0dce0306401f&rnum=1
(Reporter)

Comment 14

17 years ago
I haven't seen this for a long time myself. Is it really reproducable in later
builds?

Comment 15

17 years ago
odd, if you are asking me, then i was bothered by it just this morning (mozilla 
v0.9.8 on freebsd).

i have apache running on localhost.  on one of the pages is a link to freebsd
(http://www.freebsd.org/).  after going here & there in local pages, when i
click the link, i am presented w/ the (page on) local web root directory, even
though mozilla claims to connect to freebsd.org, and shows the freebsd url in
the location bar (but that's another bug).

after repeated tries, or playing w/ cache, or restarting mozilla seems to work
as expected.

Comment 16

17 years ago
well, my problems seem to be related to junkbuster/proxy.  after disabling
"entable keep alive", i don't get the old server for the new url anymore.
You need to log in before you can comment on or make changes to this bug.